[SOLVED] Textures loading slowly or not at all

Mche14

Reputable
Jul 1, 2017
9
0
4,520
1
So for the past year or so I've had problems with textures loading really slow or not at all. At first I just had to turn my settings to the lowest and it would fix itself sometimes, but now even on the smallest of games, things like NPC's, Textures, or characters don't even load in. I sometimes have to wait 10+ minutes just to even start playing games. This recently happened with Black Desert Online at the lowest settings (getting over 100 frames) but NPC, my own characters, buildings, and landforms wouldn't load. I thought the reason initially was something to do with my harddrive being full so I cleaned it to around 75% capacity but that didnt change anything (still could be a harddrive problem). I also noticed that smaller games like Genshin Impact and Honkai Impact would load just fine on my SSD, but not sure if the root of my problem has anything to do with specific games or hardware (or both). If theres any leads on to what problem i'm occuring or any tests I should conduct please just let me know.

P.S. I built my PC in 2016/2017 but upgraded CPU recently from a 1300X about half a year ago.

Specs:
AMD Ryzen 3600x
GeForce 1060 3Gb
2x DDR4 8Gb Ram
SEAGATE 2TB HDD
Samsung Evo 256Gb SSD

Also if there are any other details you need just throw a comment below, thanks in advance.
 

Mche14

Reputable
Jul 1, 2017
9
0
4,520
1
Something I noticed was when I launched Black Desert Online, I accidentally had another game downloading in the background. The textures loading a lot worse and slower so when I noticed the download happening I cancelled it. But after that the textures were still loading in slow. After I restarted the game and it was a lot better. Not sure if this has to do with the pre-loading of textures or if it gives any other ideas of what the problem is.

EDIT: I uninstalled and installed BDO onto my SSD and found that everything loading fast and easily. So I believe that was my problem. Thanks for the diagnostic help!
 
Last edited:

popatim

Titan
Moderator
Thats exactly it! TY!
Good news, the drive appears to be in good health and you have the better version. The dm008 version is a SMR drive and should be avoided for anything but archival use IMO.

Which motherboard do you have?
You can use resource monitor to see what is using the various systems ( cpu, ram, hdd, network) to help narrow down the culprits.
 

Mche14

Reputable
Jul 1, 2017
9
0
4,520
1
Thats exactly it! TY!
Good news, the drive appears to be in good health and you have the better version. The dm008 version is a SMR drive and should be avoided for anything but archival use IMO.

Which motherboard do you have?
You can use resource monitor to see what is using the various systems ( cpu, ram, hdd, network) to help narrow down the culprits.
I have a ASUS Prime B350-E its a Micro-ATX board.
 

Mche14

Reputable
Jul 1, 2017
9
0
4,520
1
Something I noticed was when I launched Black Desert Online, I accidentally had another game downloading in the background. The textures loading a lot worse and slower so when I noticed the download happening I cancelled it. But after that the textures were still loading in slow. After I restarted the game and it was a lot better. Not sure if this has to do with the pre-loading of textures or if it gives any other ideas of what the problem is.

EDIT: I uninstalled and installed BDO onto my SSD and found that everything loading fast and easily. So I believe that was my problem. Thanks for the diagnostic help!
 
Last edited:

ASK THE COMMUNITY