TF2 Horrible FPS

Shankovich

Distinguished
Feb 14, 2010
336
0
18,810
I put all settings on highest and I'm getting frame rates below 20 :( (resolution 1280 x 1024)

Catalyst 12.1
AMD Phenom II X4 955 BE
HD 6870
Gigabyte mobo 785G chipset (I know it's not the best, but still...)
6 Gigs memory
Ultra LSP 650 watts

I'm guessing it might be an issue with the PSU, but I can run Dirt 3 on ultra and squeeze out almost 60 fps (1280 x 1024). So is it a DX 11 conflict??? I'm getting the same issue, though not as bad, with L4D2.

If I do have a bad PSU (I know it's a bad brand, but if the wattage isn't enough), what would be a good buy around 100$. If it isn't, what on earth is going on! I know TF2 should be well above 100+ fps with my system -_-
 

casualcolors

Distinguished
Apr 18, 2011
2,043
0
19,960
Having faulty power supply usually leads to hangs, blue screens and such, not just diminished fps. You're getting nearly 60 fps with Dirt 3 maxed. TF2 and L4D are far less demanding, and coincidentally they are both on Valve's source engine. My guess is you have something enabled in your catalyst suite or your driverset isn't playing nice with the Source engine.

If you're getting nearly 60 fps maxed in Dirt 3, you should be getting 80-90 minimum in TF2 unless you're using some ridiculous setting that shouldn't be on, like 16x multisampling for instance (never bother to go past 4x msaa really).
 

ufailedx

Honorable
Apr 9, 2012
12
0
10,510
I would like to point out that I find L4D2/L4D doesn't run at full frames that it probably should on my PC and I have a 6850 so I think it's the source engine. I would just advise turning shadows to off or minimum and just bringing a few things down that is barely visible but still allows you to enjoy the game to it's fullest.