[SOLVED] Thinking PSU died, can anyone confirm?

Gimpy2k7

Distinguished
Sep 9, 2013
29
0
18,530
0
Yesterday the computer was working as normal. I turned it off for the night, unplugged it (situation in room) came back today and once plugged in there's no power going to the tower. Power button on the case does nothing, even the power button on the motherboard, Gigabyte board that has a few buttons, nothing at all.

Unplugged everything, tried different outlets and power cables I knew were working, still nothing. We have another SFF business system powered by a 4 pin connector, tried a 4 pin from the PSU in there and still nothing. Usually on the SFF system a green light is on the board when power is available but nothing there.

When I plug the 24 pin connector in I get a quick flash of the LED on the board mounted power button, but just on contact and it doesn't stay on. Other than that, no sign of power in the system anywhere.

Before running out for a new one, would it be safe to assume it's the PSU?
It's a Corsair CX750 about 4 years old.
Running older specs, 4790k and mid range Gigabyte board.

Thanks!
 
Yesterday the computer was working as normal. I turned it off for the night, unplugged it (situation in room) came back today and once plugged in there's no power going to the tower. Power button on the case does nothing, even the power button on the motherboard, Gigabyte board that has a few buttons, nothing at all.

Unplugged everything, tried different outlets and power cables I knew were working, still nothing. We have another SFF business system powered by a 4 pin connector, tried a 4 pin from the PSU in there and still nothing. Usually on the SFF system a green light is on the board when power is available but nothing there.

When I plug the 24 pin connector in I get a quick flash of the LED on the board mounted power button, but just on contact and it doesn't stay on. Other than that, no sign of power in the system anywhere.

Before running out for a new one, would it be safe to assume it's the PSU?
Thanks!
That or mobo it's flashing power then off
 

ASK THE COMMUNITY

TRENDING THREADS