Question Thinkpad x1 carbon SSD stuck in write-protect mode

Sep 16, 2020
1
0
10
0
Okay, so, for the last couple of days I've been trying to salvage the ssd in my mom's 5th gen X1 Carbon. She told me that it stopped working back in feb after an update. My assumption is that the computer died or was turned off during the update but I'm not sure. Anyways the issue is now that it will only boot into windows recovery but none of the recovery options are working (system restore, startup repair, reinstall windows all return with errors). Another thing to note is that this is a bitlocked drive (which I do have the key for) and I suspect this may have something to do with it. I've already managed to backup the entire windows partition so data loss isn't a concern and I would prefer to just wipe the whole the thing and start over. However, I have tried everything I can think of to wipe and reformat this drive and it always responds with a write-protection error or read/write error. Off the top of my head I know that I have tried:

Clearing the attributes in diskpart

delete override in diskpart

deleting all partitions in gparted through a live usb

turning off write protection with hdparm

reinstalling windows with a bootable usb

installing a fresh install of linux mint from bootable usb

I have successfully mounted and and decrypted the drive in linux using dislocker which allowed me to backup the data but still no luck with wiping or reformatting. I cannot for the life of me figure out what's preventing me from formatting the drive, I would suspect that the drive is failing but I had no issue mounting and backing it up. Any help or suggestions would be appreciated as I have googled all I can think to and have barely gotten anywhere.
 

ASK THE COMMUNITY