Question Thinkpad Yoga 11e Bios update failure and doesn't power up since

Feb 12, 2019
4
0
10
0
Hello everyone!

I have a Lenovo thinkpad yoga 11e it was working fine then last week i decided to update the laptop drivers from lenovo support website then i downloaded the bios update setup and then run it so the laptop restarted but no screen didn't turn on.i waited for atleast 30minutes but nothing then i decide to shut it down but after that when i power it up it doesn't sho anything on the display.

The thing is when i turn it on I get the red light on thinkpad logo and fn button.
What i have tried so far with no luck.
1.removed battery and hold power button for 60secs and replace back the batterý and turn it on with no luck.
2.removed battery and cmos holded power button for 60secs replaced them back but with no luck.
3.tried to hold f9,f11 and f12 while powering up with no luck
4.tried esc + f3 simultaneously with power key but wielded no result either.
So please may you help me all this resulted afteŕ the bios update failure...Hope I'll get solution.
Thank you very much!
 

ASK THE COMMUNITY

TRENDING THREADS