This is odd to me.. (wireless connection)

Moose88

Honorable
Apr 14, 2012
10
0
10,510
0
I have a Windows 7 desktop with a wireless network connection... A few days ago I booted up and it wouldn't connect to the internet, the light on the adapter would just flash slowly like it was searching for a connection. In the notification area it the wireless signal would be a grey circle. I tried for hours trying to see what went wrong, I reinstalled my network driver but it was no help. So I restored the computer to a few days back, and WALA, it started working again...

Now, it just happened again.. It wouldnt connect to my internet, I did the Diagnose problems & it first said to verify network key, then said I didnt have an IP... so I restored it again to a few days back, now its working again :/

I need to figure out why this could be happening.. I hope I can find help here. If this is a sign of my network adapter going bad? What in the registry could be going wrong? I dont know what to do...

Thank you for any help
 

RealBeast

Titan
Moderator
While it could be many things, sounds more like you installed some software that is interfering with the wireless adapter driver -- have you installed anything that uses the bonjour dns responder service, like iTunes or an Adobe product?

If so, disable the Bonjour service using services.msc (type that into the start button run window, then find that service and disable).

It seems less likely that the adapter is going out, as restoring to an earlier time would not affect that.
 

Moose88

Honorable
Apr 14, 2012
10
0
10,510
0
I do have both iTunes and Photoshop so maybe that was it.. I disabled Bonjour, I will report back with results.

Thank you Realbeast. Thank you VERY much.
 

Moose88

Honorable
Apr 14, 2012
10
0
10,510
0
well I got back online after a reboot but I will have to wait and see if it changes in a few days..

I do notice that in the Notifications tray, the Internet signal takes awhile to show the Bars... it will do that Grey circle like its looking for a network for about 2 minutes before itll show as connected..

It used to show connected as soon as it loaded in my Tray, there was never a wait. But for some reason now it lags ever since this problem has started...
 

Moose88

Honorable
Apr 14, 2012
10
0
10,510
0
Well it happened again.. I booted up this morning, it wouldn't connect so I restored to the latest restore date (the 17th) and it connected.. It took a few seconds but it finally started..

Bonjour is still disabled.. Any other ideas?
 

RealBeast

Titan
Moderator
What encryption are you using, WEP or WPA? Also in your router advanced wireless settings turn off access list if it is on.

And last idea is to turn off NetBIOS, which you don't need and can cause issues in Windows 7: In Network Connection Control Panel click properties on your wireless connection. Select Internet Protocol Version 4 > Advanced > WINS tab > NetBIOS setting and then select disable NetBIOS.

Good luck.
 

Moose88

Honorable
Apr 14, 2012
10
0
10,510
0
Ok I cannot fix this. I need someone to help me. I keep having to do system restore to get my internet back.

I tried to do a repair install but it said I cannot do it with the disk I have because "I have a newer version of windows that is on the disk"

It wont let me.

Is there a way I can post up some kind of log that someone can use to figure this out? Restoring is beginning to become a pain the butt.

Please help me.
 

RealBeast

Titan
Moderator
At this point your best option is to do a repair installation of Windows 7 -- look here: http://windowssecrets.com/top-story/win7s-no-reformat-nondestructive-reinstall/

A repair install will not affect any of your programs or data (of course back up key data anyway first), but will completely reinstall windows and then you need to reapply all patches. The advantage is that it fixes all registry issues that cannot be otherwise fixed, like yours.
 

Moose88

Honorable
Apr 14, 2012
10
0
10,510
0
There is no tool I can use that repairs registry? I tried to use my Upgrade disk and like I said, it told me I couldnt do it because the version of windows that I am currently on is newer than the disc. So it failed.
 

RealBeast

Titan
Moderator
You can download a trial image of the same version of Windows that you use that is the latest image (and yes it is all legal and okay) to use, just select the correct version. Go here: http://www.mydigitallife.info/download-windows-7-iso-official-32-bit-and-64-bit-direct-download-links/

You are beyond registry repairs, since you cannot determine which registry values are corrupted.