[SOLVED] Toshiba L50-B - No bootable device found after replacing battery

Crazysealions

Reputable
Feb 3, 2015
107
0
4,710
7
I am having problems with my Toshiba L50-B, I bought it used from someone without a battery so I had been using it without a battery for a few days but everytime I restarted the computer I would get an RTC battery low message so I decided to buy a battery.

I received the battery and charged the laptop up to 100% and then after using it I shut it down. I then turned it on and no more RTC battery low error but now I got the error -No bootable device, Please restart system- so I restarted the laptop and the same error keeps appearing. I then decided to go into the BIOS and once in the BIOS I noticed that under HDD it says none so it is not detecting the hard drive in the BIOS so all I did was go to the Exit tab in the BIOS and Save changes & Exit bios and after exiting the BIOS it restarts the computer and everything works fine I get into Windows 10.

The problem is that after I shutdown my computer everytime and then turn it back on I need to do this same procedure everytime - Please note that I am not even changing anything in the BIOS or resetting it to default, I simply select Save changes and exit and then it works until the next time I shut down the laptop and turn it on.. This problem only started happening after adding a battery to the laptop.

I also want to add that this series of laptops does not have a CMOS battery it has EPROM to save the bios & time/date

The hard drive in the laptop is brand new and has been tested.
 

ASK THE COMMUNITY

TRENDING THREADS