Question Toshiba satellite L50 not powering up

Nov 4, 2019
1
0
10
0
Hi, I have a Toshiba Satellite L50 here and its not powering up.

The owner said it just sat in its box in a cupboard for 5 years and now it wont turn on

It would give a Power LED and a Charge LED but press the power on button and nothing not even a fan noise or anything.

Opened it up and checked the power button and cable with a multimeter and seems ok

No CMOS battery as apparently the laptops battery works as a cmos battery as well.

Tried removing all hardware still nothing

Left the battery on charge all day, the next day it was only reading 3 volts.

Ordered a new battery and inserted it and the power on button lit up I thought It was sorted but no, that was all it did so had to remove the battery to turn it off.

Put the battery back in and now nothing not even a power or charge indicator when the mains is connected

Removed battery and still not even a power or charge indicator. Checked battery voltage and 14 volt

Mains charger giving 19 volt

Sound like a dead board?

Thanks
 

ASK THE COMMUNITY

TRENDING THREADS