Question Touchpad not working | Y530 ICH

Dec 17, 2019
5
0
10
0
Hello,

I recently found out that something was wrong with my laptop and when I put it to sleep, opened it up the trackpad sometimes didn't work which forced me to restart the whole laptop. Other times when I put it to sleep it shut itself down even with the option in control panel ("Choose what closing the lid does") being on sleep, and one time it even went to blue screen when I shut down the laptop itself (not forcefully).

I don't know whats causing this, I've went on lenovo's application and tried updating everything, even on the intel software updater I've updated everything to the max and nothing has helped it so far.
Right now I only care about the trackpad, I tried installing drivers manually but found out that on the device manager under "Mice and other pointing devices" I only had HID-complaint mouse and not the trackpad itself.

Picture of the Device Manager

Any help would be appreciated (bios is also updated).

Thanks.
 

ASK THE COMMUNITY

Latest posts