Question TP-link AV600 Works worse than asus nano usb stick

Jul 27, 2020
18
2
15
0
hi there, i recently purchased a TP-Link AV600 Powerline adapter, and it honestlyt sucks. it has worse speeds than my asus nano wifi chip or sometimes it doesnt even work. ive tried alot of things to make it work but it just wont. also, when i plug it into the router, it goes to the wrong network. it should be on "Network 1" Instead of "network 2" which it is currently on (exanple names btw) any ideas? pls help asap. TY!
 
Jul 27, 2020
18
2
15
0
what do you mean exactly? its a powerline adapter that goes from my outlet to the outlet behind my tv and into both router and pc
 
We need to go visit tplink marketing guys with a baseball bat.

TPlink has a history of being jerks and changing stuff and not changing the part number. In this case they renamed their av500 units av600. They hope nobody notices that it is not av2-600. The av2 standard is much better and newer. Lately though they have been calling devices based on av2-600 av2-1000 and av2-1200 av2-2000. Not sure why the standard is 600 and 1200.

All you can do is try different outlets.
 
Reactions: SamirD
Jul 27, 2020
18
2
15
0
We need to go visit tplink marketing guys with a baseball bat.

TPlink has a history of being jerks and changing stuff and not changing the part number. In this case they renamed their av500 units av600. They hope nobody notices that it is not av2-600. The av2 standard is much better and newer. Lately though they have been calling devices based on av2-600 av2-1000 and av2-1200 av2-2000. Not sure why the standard is 600 and 1200.

All you can do is try different outlets.
I’ll try, thanks.
 
what do you mean exactly? its a powerline adapter that goes from my outlet to the outlet behind my tv and into both router and pc
Well, that's the way it should be so that part is right.

But the speeds will vary depending on what type of noise you have in those outlets. Also, don't use it with a surge strip.

If you suspect they're bad, plug them both into the same outlet and check what type of speeds you get through that.

av600 isn't that capable though--you'll be lucky to see 60Mbps.
 
Jul 27, 2020
18
2
15
0
Well, that's the way it should be so that part is right.

But the speeds will vary depending on what type of noise you have in those outlets. Also, don't use it with a surge strip.

If you suspect they're bad, plug them both into the same outlet and check what type of speeds you get through that.

av600 isn't that capable though--you'll be lucky to see 60Mbps.
oh ok,it’s in a power surge. I’ll try taking it off rn
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts