Question TP Link router taking forever to connect and receive an IP address from the MT LINK XPON SFU ONU. WAN address 0.0.0.0.

Aug 8, 2022
2
0
10
0
I recently upgraded to a fibre network and the ISP installed a couple of additional devices to my previous setup. Initially, the fibre wire goes through a box that converts it into a different sort of cable, and then that cable connects to the MT LINK XPON SFU ONU(which I guess is the modem). Then, via an ethernet cable, it connects to my router (I mentioned this because before any of these devices were added, I never had this problem). The MT Link device seems to be working fine however, the tp link router displays a red light. The TP-Link page indicates that the router is trying to connect and get an IP address but it is taking forever to do so. Interestingly, sometimes, just restarting both the devices a couple of times, results in the router working and I have internet access but most of the time this just doesn't work. This usually happens when for some reason I have to restart the router. Any fixes?
 
Last edited:
Those mtlink boxes seem to be used only in limit areas of the world so it is hard to get information.

I assume you have the simple one that has a single fiber going in and a single ethernet port coming out. This is pretty much a simple gpon modem from what I can tell. There are other models that are actual routers that have more ethernet ports.

The generic issue you likely have is related to the ISP DHCP server and it giving your router a IP. This is mostly in control of the ISP. What some of these gpon boxes do is similar to what a cable modem does. They lock the first mac address they see. If you change the device you plug in you have to reboot the modem first then plug the router into it. Sometimes you test by plugging a pc in and then a router but without a reboot it will still be locked to the pc mac address.

Not sure this all a guess. Maybe the log on the tplink will tell more about why it has issues getting a IP. It may not even be dhcp if the ISP is using PPPoE.
 
Aug 8, 2022
2
0
10
0
I have been provided with a username and password that I need to enter under the PPPoE connection setting. Also to mention, a secondary "Dynamic IP" option is also enabled. There is also a MAC clone option under the Networks tab which states
"Most Cable ISPs (Internet Service Provider) register the unique MAC Address from the wired connection on your MAIN COMPUTER - the last computer used to be connected with the Cable Modem and had an Internet connection.
If you add a router to the network, your ISP may not recognize the MAC address of the router and not allow it to connect.
However, the TP-Link router can "clone" or replicate the registered MAC address of the MAIN COMPUTER. Then your ISP can release the Internet connection to the router and all the computers."
 

ASK THE COMMUNITY