Question tp-link tl-wn881nd not detected?

Blissz

Reputable
Oct 7, 2014
17
0
4,510
0
For some reason, my tp-link tl-wn881nd suddenly stopped working and to my findings, mobo just stopped detecting it? This wifi adapter has been with me for like 8 years, is it time to say goodbye? Device manager doesn't detect it, i have the driver disk but it couldn't detect the adapter too. The status light indicator from the adapter doesnt light up as well. My main thing though is what of its only my mobo pci slot? I know wifi adapters arent that expensive but can someone help?
 

Lutfij

Titan
Moderator
You can take the wireless adapter and try it on another slot in a donor system to rule out an issue with your system itself and to see if the card itself is truly dead.

Speaking of system's when posting a troubleshooting thread, it's customary to include your full system's specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Also make sure you're on the latest BIOS on your motherboard.
 

Blissz

Reputable
Oct 7, 2014
17
0
4,510
0
Specs:
i5 3.10ghz ivy bridge
Gigabyte h77d3h mobo
2x4GB Ballistix RAM
Evga Gtx 750ti 1GB
CM 850W PSU
1TB WD HDD
Windows 7

Ive already tried plugging it on a different slot still nothing.
Bios is not updated and couldnt update it if wifi is not working. I tried reinstalling my motherboard though because I have the driver disk that came with it but still nothing. Do take note that this just suddenly happened after turning on my PC so I'm not sure if other components are causing problems or do they?
 

ASK THE COMMUNITY