Question TP Link WN88ND V2 Issues

Oct 12, 2019
2
0
10
0
Most of the time when I start-up my PC my WiFi card does not pick up any networks, however if I reinstall drivers the issue gets fixed. The adapter also works without the drivers on the CD that is given with the card, but also has the issue of not working on start-up. I had initial issues with a USB adapter that was giving very high latency between my pc and router, so I bought a TP link WN881ND V2 card. I still had high latency, so I had the adapter replaced with the same type of card ( WN88ND V2 ). Now I have the issue of occasional high latency and frequently have the issue mentioned at the beginning of the thread. Any ideas on what could be the problem?
 

gggplaya

Distinguished
Jan 27, 2011
853
36
19,040
7
If this is on a desktop, you may want to try switching to powerline or moca network adapters to connect to your main router. Seems like maybe you're at the edge of distance to your router. Try temporarily moving your desktop closer to the wifi router to see how stable it is. If it works better while being closer, then you're definitely at the edge of range.
 
Oct 12, 2019
2
0
10
0
If this is on a desktop, you may want to try switching to powerline or moca network adapters to connect to your main router. Seems like maybe you're at the edge of distance to your router. Try temporarily moving your desktop closer to the wifi router to see how stable it is. If it works better while being closer, then you're definitely at the edge of range.
Hi gggplaya, I'm sure that I'm not out of distance of my router as I'm a couple of meters away from it however there is a wall between us. Ethernet isn't an option either. I didn't have this problem until a few weeks ago so im positive im not on the edge of my routers range. Thank you very much for helping!
 

gggplaya

Distinguished
Jan 27, 2011
853
36
19,040
7
What I did to fix that problem was purchase an asus router and configured as a media bridge. This uses all the wireless AC antenna's to connect to the main router and gave me ethernet to my desktop.

The problem was, when I was gaming and had fortnite tracker open on my other monitor. Every time the web page refreshed, my ping would jump to over 300-400ms for 1-3 seconds. It was incredibly annoying. It's something to do with how windows 10 handles wifi traffic with wifi adapters.
 

ASK THE COMMUNITY