Question tplink c80 issue getting time from internet

ravin_29

Commendable
Mar 24, 2019
56
0
1,530
0
About 2 weeks ago, I purchased tplink archer c80 wifi router. Router is good in its features but I find one issue. In system settings there’s an option to set time and my choice is to set it using internet time servers.
No matter what NTP server I mention there, router always returns time out error. I have tried over dozen different ntp servers by server name as well as ip address but it always says time out.
Router software is latest and I did not check with previous software, first thing I did was update the software.
I have another old router provided by isp some cheap brand and on same internet connection service / setup , same ISP it never errored out. It always got time from ntp server. I also tried time sync on my windows 10 laptop connected to router and it did so correctly. So I think there’s no ISP issue here. Something is wrong with tplink c80.
Can someone help me in further troubleshooting? Do you think this could be software error?
I can not use scheduled tasks/ parental control and other time based features now. Purchase return window from amazon has ended so can not return it to seller. Since device is under warranty not willing to try ddwrt or openwrt etc. thankyou.
 
Not sure I have not looked at tplink in a while. Are there firewall rules or other security setting that prevent the router from talking to things on the internet. I know for example you can't configure most routers from the internet and some will not even respond to ping unless you turn it on.
 

ASK THE COMMUNITY