Question TPM 2.0 Chip Causes PC Not to POST, Removal Fixes Issue: Using Gigabyte TPM Chip on Asus Mobo

tburke89

Distinguished
Jan 23, 2013
22
0
18,510
0
tl;dr - I read Gigabyte 14-pin TPM chips that fit onto Asus 14-pin TPM headers will necessarily work; but I tried & it didn't, is it me / the chip / or bad info?

Imgur link with a screenshot of the datasheet for the chip + photos of it. Motherboard is Asus Z270e: View: https://imgur.com/a/d6gzdYX


So, I am trying to install a TPM 2.0 chip to my Asus Z270-e motherboard. I did quite a lot of research and despite many commenters claiming that each motherboard manufacturer required their own proprietary TPM add-in-cards be used, there were many others who said that so long as the cards were of the right type & pinning that you could indeed use 3rd party TPM chips with your Asus, Gigabyte, etc. motherboard. I read a fairly lengthy and well researched effortpost made by someone either on here or reddit who broke down exactly why different manufactures TPM modules could & would work on any motherboard that had the capacity to install one of these security devices onto it.

Specifically it was mentioned that for Socket 1151 motherboards made by either Asus or Gigabyte both used the same type of 14 pin TPM header on their motherboards using the same technology and since at that time there were a lot of Asus 14-pin TPM chips and Gigabyte TPM chips on the market, this user claimed that owners of either brand motherboard just purchase whichever 14-pin TPM chip they had access to and was most convenient and affordable.

I followed that advice and purchased a "Gigabyte 14 Pin TPM 2.0 Chip" off of eBay from a domestic US seller. At that time auctions for these chips were all ending >=$60 so I was relieved the seller accepted my offer of $15.

I got the TPM chip in the mail last week and I powered down my computer. Connected my anti static bracelet just to be safe. The 5th pin on the second row is blocked off, which fits perfectly onto my motherboard which is missing that pin. I have UEFI enabled and TPM enabled in my BIOS. I power on the machine, and.... nothing. My monitors all go into standby mode. The machine never posts, though the motherboard lights up and the CPU and chasiss fans spin. As soon as I pull the chip off of the motherboard, boom, it immediately POSTS and forces me into the BIOS. Which I can just exit w/o change and boot into Windows.

I have retried this several times to no avail. I guess Gigabyte 14 pin TPM chips do not necessarily work with Asus 14 pin TPM headers? It was not just one commenter who convinced me, there were many posts I read on several platforms that all said that this should work. Is it a problem with how my BIOS are configured? Or am I missing a step here to do this correctly? Is the chip itself faulty and should I return it to the seller as such? Any advice is appreciated, thanks!
 

ASK THE COMMUNITY

TRENDING THREADS