[SOLVED] TPM clearing issues, Please help, I’m clueless.

Leandroc04

Prominent
Feb 11, 2019
4
0
510
1
I recently ordered parts to build a new pc, so I was planning on selling my current one to a friend. However, upon reseting the pc and then restarting it, I ran into an issue with “TPM” - Whatever that is. When the pc is booting up after a restart or powering on, the first screen you see after the word “LENOVO” (I have a lenovo y520t, model 90H7007AUS) is a screen that says “press f12 to clear TPM” or “press ESC to continue”. However upon pressing either keys or any keys, nothing happens. The screen then sits there for 3-5 mins before bringing me to the lock screen. I tried restarting the pc to enter the bios but it just goes straight to the TPM screen. Please help me as I am clueless and this is honestly the first time even seeing the TPM.
 

Leandroc04

Prominent
Feb 11, 2019
4
0
510
1
I FIXED IT! Finally after exhausting what I thought were all my options, I decided to just hook up an old dell keyboard and “BOOM!” It worked. When I booted up the pc and saw the tpm screen I hit f12 to clear and it finally worked. Thanks for the help though man I appreciate.
 

Leandroc04

Prominent
Feb 11, 2019
4
0
510
1
Thanks for the response. When trying the first solution, the tpm management window was different because I have windows 10 not 7, but when I clicked clear tpm, and restart, it brings up the same window I talked about earlier.
When It came to the second solution, I couldn’t do that one because I cannot enter my bios (For my specific model of pc, the bios key is hold f1, but my bios doesnt appear when performing it as the TPM error/warning screen comes up, and again, my keyboard does nothing). I appreciate you trying to help though, and if you have any other ideas i’m all ears. Thanks.
 

Leandroc04

Prominent
Feb 11, 2019
4
0
510
1
I FIXED IT! Finally after exhausting what I thought were all my options, I decided to just hook up an old dell keyboard and “BOOM!” It worked. When I booted up the pc and saw the tpm screen I hit f12 to clear and it finally worked. Thanks for the help though man I appreciate.
 

ASK THE COMMUNITY