[SOLVED] Tried to install RGB light strip and now the Mobo won't turn on

Feb 26, 2019
1
0
10
0
So I had a working computer till I decided btobadd some RGB lights to it. The were ASUS ROG Addressable RGB 5050 LED 60cm Lighting Strip with Magnetic Backing and Adhesive Strips for use with AURA Sync RGB which I figured would be compatible with my Asus B450m tuf gaming motherboard. However the connection for it seemed to be not quite right for the RGB header. I tried it a couple different ways and then I tried it one way on the 4 pin witht the pin connector and computer turned on then shut off.

Now the computer won't turn on even thought the motherboard led shows power is going to it. The LED light on the power button no longer lights up though.

I think my Mobo or case shorted out.

I'm not sure this has been my first computer bulld and it's been miserable. Alright had to get a different a Mobo cause the first one came in bad. Had to get another m.2 drive cause the other one had issues and now this. Any advice would be appreciated cause I just want to finish this build but nothing seems to be going right.
 

cin19

Titan
Moderator
However the connection for it seemed to be not quite right for the RGB header. I tried it a couple different ways and then I tried it one way on the 4 pin witht the pin connector and computer turned on then shut off.
May try to remove all the RAM, boot device, GPU, and the RGB strip too, clear the CMOS. After that boot the PC to see what happens, if the PC does the same, yes, you may kill the MB.
 

cin19

Titan
Moderator
However the connection for it seemed to be not quite right for the RGB header. I tried it a couple different ways and then I tried it one way on the 4 pin witht the pin connector and computer turned on then shut off.
May try to remove all the RAM, boot device, GPU, and the RGB strip too, clear the CMOS. After that boot the PC to see what happens, if the PC does the same, yes, you may kill the MB.
 

ASK THE COMMUNITY

TRENDING THREADS