• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Trouble Installing Drivers

Jun 6, 2020
9
0
10
0
Hello everyone, this is my first post here so I apologize if it's in the wrong place, or formatted incorrectly, but I'm losing my mind.

I recently built a new pc, but after reinstalling WIN10 I'm having issues installing my monitor and driver. I've read about a million support posts and watched another million youtube videos. I've gone through all the regular steps to fix the issue.

The basic issue is that my monitor is a 144hz monitor, but I cant get rid of the generic PNP monitor driver and replace it with my monitor's driver.

Here's what I've done so far:

I have a VG248QE monitor. I first looked online on Asus's website to download the driver. After selecting the correct product, the only download available was a program called Asus Multiframe, which doesn't appear to be a driver. However, having no other option, I downloaded it and ran the setup file. It has done nothing, and for the life of me I cannot replace the generic PNP monitor. I've also made sure my graphics card is up to date, so that's no the issue either. Please help me either find the correct driver, so I can install it properly or tell me what I'm doing wrong because I'm going insane.
 

Darkbreeze

Titan
Moderator
You don't need a driver for your monitor. Monitor is simply plug and play. Very few monitors have actual "drivers" although a few do have "profiles" you can download for them. It is unimportant however. What IS important is that you have the proper graphics card driver installed and in many cases, that you do a CLEAN install of that driver using the latest available version of the driver. You don't need to worry about your monitor showing as "PNP monitor". That's pretty much normal.

One thing you CAN sometimes do, and again, it's totally NOT necessary, is open device manager, click update driver and select Browse my computer for drivers. Then click Let me pick from a list of available drivers on my computer. Uncheck "Show compatible hardware" and then browse the resulting list for your monitor model. Select it if it is there, don't worry about it if it isn't and close the window out by clicking on cancel. There is a profile available for that monitor for the Windows 8 OS, but it is not compatible with Windows 8.1 or 10.

This is all ASUS multiframe is, not driver related in any way.


What is the model of your graphics card or the model of your CPU if you do not have a discreet PCIe graphics card installed?
 
Jun 6, 2020
9
0
10
0
Thank you for the reply.

If I don't need a driver how do I get my monitor to run at 144hz? Generic PNP only goes up to 60hz right now but my monitor goes to 144. Also, as I said. I have the latest GPU driver. I installed it when I first built the PC.

The GPU is EVGA's RTX 2080 Super

CPU is i7 10700k

idk what PCI is or how to install it
 

Darkbreeze

Titan
Moderator
What kind of display cable are you using to connect to this monitor? What are your FULL hardware specifications including model numbers for CPU, motherboard, etc?

You may also have to change some Windows settings. You can right click the desktop, select Display settings, make sure the monitor in question is selected at the top if you have multiple monitors, scroll down and click on "Advanced display settings", make sure your monitor is selected from the drop down menu where it says "Select a display to view or change the settings for it" and then down below click on "Display adapter properties for Display 1" (Or something similar). See if the mode you desire is available from the list of modes available in the menu that pops up when you click on List all modes.

If you are using the wrong cable type it's possible that 144hz won't be available no matter what you do. Since your monitor supports HDMI 1.4 and your graphics card supports HDMI 2.0 it should be available with both HDMI and Displayport. If you are using DVI you need to have a dual link DVI-D cable that is capable of 144hz. Best bet is to simply use Displayport though. Many users have not had success in the past with DVI or HDMI even though it's technically possible.
 
Last edited:
Jun 6, 2020
9
0
10
0
I'm using an HDMI 2.0 cable, specifically this one https://www.amazon.com/gp/product/B01N343SBS/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
that I bought a couple days ago.

I'll post my dxdiag if you want me to, but first I'll try just telling you the big things first.

Motherboard is ASUS Z-490
CPU is i7 10700k
GPU is EVGA GEFORCE 2080 Super

I'm not really sure how to get the model numbers.

I double checked display settings and the correct monitor is selected. The drop down menu still only goes up to 60hz.
 

Darkbreeze

Titan
Moderator
In the Nvidia control panel, make sure you have the CORRECT resolution set and that it is the one listed under the "PC" subtitle. Not any other 1080p or 1920x1080 resolution. In fact, open Nvidia control panel, click on the resolution listing on the left and then take a screenshot of the resulting page. Make sure it shows what the current resolution setting is on that screenshot and page.

 

Darkbreeze

Titan
Moderator
Change it from that setting to the 1080p setting under "PC". Then you should see an option for 144hz.

Scroll down, under PC select 1920x1080 or 1080p, then click ok. Then go back and check for 144hz in the drop down beside the resolution. I'll bet it will be there.
 

Darkbreeze

Titan
Moderator
Set it to 1920x1080 under PC. Then click Apply. Then restart the computer. Then go back into Nvidia control panel and now check the drop down beside the resolution setting. Also, make sure the resolution has stayed with what you set and hasn't changed back to Ultra HD, HD, SD 1080p.

Also, now that you've selected PC 1920x1080, go into the (Right click desktop) Windows display settings like I outlined earlier and look to see if the option is available there. You shouldn't need to do that because it should be available in Nvidia control panel but maybe. It's also possible that this monitor is simply not going to do it with HDMI and that you may HAVE to get a DP cable. It would not be the first time I've seen a monitor refuse to play ball. How long is the cable you are using? What brand is the cable? Yes, those things can very much matter.
 
Jun 6, 2020
9
0
10
0
Now that you mention it, yeah it keeps switching back to the Ultra, HD, etc. setting.

I followed all the steps and still not luck.

The cable I'm using is 6ft long, I have gotten 144hz to work on it before, but that was on my old PC with a DVI cable. Of course, most modern gpu's nowadays don't have DVI ports anymore, including mine.
 

ASK THE COMMUNITY

TRENDING THREADS