Trouble SAMBA Sharing Hard Drives Connected To ASUS Router

Majoraslayer

Reputable
Jan 14, 2016
14
0
4,510
1
Background: I have an ASUS RT-AC68U router and a dual HDD enclosure connected to it via USB 3.0. This router has a file sharing feature that allows you to connect hard drives to it and set up multiple types of media servers or a SAMBA share. My PC is running Windows 10.

I have this setup working.....kind of. There are some issues with it that I can't figure out. The media server feature works perfectly; VLC player makes for a handy way to take advantage of it with my phone when I connect to the network over wifi. However, I know virtually nothing about SAMBA, and I'm having the following issues with that feature:

1. The router should appear in my network folder on my PC as another computer on my network to access shares. It refuses to do this. I have to manually type in the router address to access the shares.

2. I mapped the drives on my PC successfully while the router was set to allow guest access. However, when I attempt to delete files I'm working with on the network drive, random files say I don't have permission to delete them. These files seem to be completely random (10 songs in an MP3 folder etc.). I've tried changing my connection credentials to match the username I use on the router (and is listed with full r/w access in the SAMBA tab of the web GUI), but it makes no difference.

3. I tried turning off guest access, and the mapped drives disconnected on my computer. When I try changing the connection credentials to match the account listed in the web GUI for SAMBA, it says my login is invalid. I tried adding another account and giving it full read/write access to the drives, but once again it refused to accept the login information.

My username is the same as it is on here (Majoraslayer), and the device name for the SAMBA share is ZDNetwork. When I receive the error messages preventing me from deleting files (and its just random files, most I can delete just fine) it says I need permission from "ZDNetwork\Majoraslayer". I tried putting in that full address as my username and it STILL doesn't recognize it as a valid login. The workgroup name in the SAMBA settings is set to the default "WORKGROUP", but I can't seem to find that specific setting in Windows. I can only find the homegroup setting, which is another strange occurrence in itself; I get a message saying I'm invited to join a homegroup, but when I input the password for the last homegroup I set up on my network it says the homegroup is no longer available. As best I recall the default workgroup in past version of Windows was already set to "WORKGROUP", but the homegroup feature has kind of buried it since Windows 7.

The PC has a fresh install of Windows 10, so its possible there are default settings in Windows I need to change but I'm overlooking. If anyone can provide some advice I would really appreciate it!
 

Majoraslayer

Reputable
Jan 14, 2016
14
0
4,510
1
Well, no one had any luck answering this so I guess I'll share my solution. It turns out the attributes of random files and folders were set to read-only. It would be nice if Windows could distinguish when that's the issue instead of telling you that you need permission from your own user account to make changes. As it is the symptoms are the same as if you had an account name setting wrong somewhere.
 
Aug 14, 2019
1
0
10
0
This post is old however when I found myself searching for credential problems with my Asus router I could not find the answer. My solution and realization was that when setting up a samba user in ASUS and merlin firmwares you can not use special characters in your password. If you find yourself having credential issues for your samba share try creating a user and password with no special characters especially if your samba is on your private network. Because Asus routers use old versions of Samba maybe they don't support using a more secure password. There was nothing annotating that you could or could not use special characters in the password. If that doesn't work, If you are using windows 10 open up the credential manager and remove that credentials saved for your drive under windows credentials. Then open the network location and re-enter them when it asks you. I don't claim to be a professional however this is merely what has worked for me.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS