• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Trouble with audio ouput with Logitech z506 speakers to ASUS TUF Gaming x570 Plus

Jun 27, 2020
1
0
10
0
I've just built my PC and was trying to connect my Logitech z506 5.1 speakers but haven't been able to get any output connecting them to my PC.

The instructions and cables connecting from the speaker to the PC look like this:
View: https://imgur.com/a/gUc2O


My Mobo's backpanel:
View: https://imgur.com/YG5kVhW


I've connected the Green cable to the Line Out port, Black cable to the Rear port and Yellow cable to the C/SUB port. Does anyone know if this is indeed the correct way to plug the speakers in?

Assuming I'm correct with the cables plugged in, I've tried these methods to try to get some output:
  1. I've tried installing and reinstalling the latest Audio & chipset drivers from my ASUS motherboard support page but I still can't get any output to played via the speaker.
  2. The mobo manual also doesn't seem to make sense with respect to the speakers i'm using. I've tried the configuration in the manual and it still doesn't work.
  3. I've tried switching "Realtek Digital Output" and "Realtek Speakers" but there is no difference as well.
I'm not entirely sure what is wrong and was hoping for some direction or advice. Any help would be greatly appreciated!
 

ASK THE COMMUNITY

TRENDING THREADS