Question Trouble with every browsers. Please help.

Tiakii

Commendable
Apr 19, 2017
14
0
1,510
0
So recently, I've been having problems with chrome, and every other browser. It's completely slow and I'm not able to google anything, when I do I just get the following message "www.google.com took too long to respond.", and when I run the diagnostic tool, I get no errors. This has been going on for about a week, but links work fine. Yesterday my YouTube has been bugging out as well, I'm not able to click on any YouTube videos unless I open it in a new tab, YouTube links don't work either.


UPDATE:
I found out that I'm not able to connect to google server and it seems like the problem isn't on my end, and I've contacted my isp.
 
Last edited:
Most common would be a DNS issue but you would have to do some testing to be sure.

I would hard code the DNS in the ipv4 nic settings on your pc. You can also disable ipv6 support.

If blindly changing this does not help then it could be your internet connection is having a issue and you will need to do more detailed testing.
 

Tiakii

Commendable
Apr 19, 2017
14
0
1,510
0
Most common would be a DNS issue but you would have to do some testing to be sure.

I would hard code the DNS in the ipv4 nic settings on your pc. You can also disable ipv6 support.

If blindly changing this does not help then it could be your internet connection is having a issue and you will need to do more detailed testing.
I disabled it and still no luck.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS