Question Troubleshooting: ASRock X299 Taichi XE System

rbookout3

Reputable
Sep 8, 2016
22
0
4,520
1
The Good:
MB: ASRock X299 Taichi XE
CPU: Intel i9-7940x
CPU Cooler: Corsair AiO H150i Pro
RAM: G.Skill TridentZ (4x16GB) DDR4 3200
GPU: MSI GeForce GTX 1080 Ti
PSU: Corsair HX850i 850W Plus Platinum Modular
Boot: Samsung 970 Pro 512GB M.2 SSD
Storage: Intel 760p Series 512GB M.2 x2 in RAID 0 (For games and adobe scratch) and other basic hard drives for different storage needs.
OS: Windows 10 Home 64bit

The Bad:
I built this myself about 3 years ago and I hired a small computer company to overclock the CPU (4.2 GHz) and RAM (3200) because I don't know how to, didn't want to screw anything up, and didn't have time to figure it out. I also wasn't looking for anything crazy and just wanted a small adjustment to get the most out of my rig. It's been running like a champ since then.

The Ugly:
I was at a LAN party a few days ago at a friends house and we overloaded something. We didn't pop a breaker. One of the surge protectors flipped off due to some overload and the three computers (mine included) shut down unexpectedly. We had 3 computers and a router pulling off one plug connected through various surge protectors. No lightning or storms or anything else. Moved 2 PC's (mine included) to another plug and booted up. The other computers turned on, no problem but mine wouldn't get past post. It stopped at the ASRock logo. Keyboard wasn't registering and "A0" was the debug code the MB was giving me. Shut down, pushed the Clear CMOS button on the MB which restarted the PC. I was able to boot into BIOS, didn't change anything, saved and exited. Computer restarts normally. Didn't think much of it, played games, shut down, went home.

Same problem persisted at home. Now anytime I need to restart/shutdown I can't get the comp past POST. I have to clear the CMOS, get into BIOS, save and exit without changing anything to boot into windows.

Troubleshooting:
I have updated the BIOS which cleared all the settings I had back to factory default. Same problem after restart. Clear CMOS - BIOS update stayed, saved and exited, booted into windows.
I had to set up my RAID 0 configuration again because of the reset. No problems with that.
I tried overclocking the RAM with XMP but then I'd get a debug code of 32 - might be user error. I reset my settings and I'm not messing with it or OC my CPU until I get a clean reboot.

My CPU and RAM is not over clocked. Still getting same A0 problem and have to reset CMOS to get computer to boot.

I don't have any spare DDR4 RAM to troubleshoot with but I removed each stick (following the placement of RAM according to MB's manual) until I was down to one stick of RAM. I tried each stick in the first position (C1) one at a time and kept having same A0 problem. My computer is reading all 64GB with all sticks installed and I'm not crashing in game or under heavy load with any of my normal programs. So I don't think it's my RAM or else I'd see the system failing in other places or for other reasons. At this point I don't know what to do. Maybe it's my boot m.2 drive? I don't have any other spare parts to troubleshoot with. The whole thing doesn't make sense as to why it started having problems in the first place. Not having enough power in a circuit with other computers pulling power should pop a fuse and/or just shut everybody down. Not overload a persons computer, right?

Maybe one of you smarter and more handsome persons can shed some light. Appreciate any help!

Debug Codes:
A0 -
Problem related to SATA devices. Please re-install
IDE and SATA devices. If the problem still exists, please
clear CMOS and try removing all SATA devices.

32 -
Problem related to memory. Please re-install the CPU and
memory then clear CMOS. If the problem still exists, please
install only one memory module or try using other memory
modules.
 
Last edited:

ASK THE COMMUNITY