[SOLVED] Trying to boot into UEFI mode with Bios mode set to Legacy?

Nov 23, 2020
19
1
15
0
When i try to boot with CSM disabled my nvme with win 10 doesnt show in boot menu.

I checked drive management. My nvme is GPT. It has two paritions. C: with windows installation and F: with my online games.

Please help me boot up in UEFI mode.
 
Last edited:

Colif

Win 10 Master
Moderator
i can tell the answer to - Did you have other drives attached when you installed to NVME? - is yes as the boot partition is on disk 1, D drive. System partition - Where PC is booting from.

NVME is booting off Disk 1. Which has to be MBR since it doesn't have an efi partition.

If you want to use UEFI boot on that PC you will want to start again.
remove all other drives when you install on NVME, that will stop windows repeating this. It was trying to be helpful, it saw a boot partition on D and used that instead of making one on Disk 0 like it should have.
 
Reactions: Mickey Sood

Colif

Win 10 Master
Moderator
what motherboard do you have?

its possible it shows in a storage menu, some motherboards don't show NVME in boot order.
Does BIOS have a choice called Windows Boot Manager in the boot menu as it may include the GUID of the GPT drive in s list of boot drives. GUID = Global Unique ID, every GPT drive on earth has its own id.

IF CSM is off it should be in UEFI mode. CSM = Compatibility System Module. Its role is to emulate an old bios prior to UEFI being introduced in 2009.

I checked drive management. My nvme is GPT. It has two paritions. C: with windows installation and F: with my online games.
that won't work then, it doesn't have a boot partition. Was there another drive in the PC when you installed win 10 on NVME? As it would appear to me win 10 has just added its boot details to the other install.

can you show a screenshot of disk management with all drives attached. Upload to an image sharing website and show link here.
 
Reactions: Mickey Sood
Nov 23, 2020
19
1
15
0
what motherboard do you have?

its possible it shows in a storage menu, some motherboards don't show NVME in boot order.
Does BIOS have a choice called Windows Boot Manager in the boot menu as it may include the GUID of the GPT drive in s list of boot drives. GUID = Global Unique ID, every GPT drive on earth has its own id.

IF CSM is off it should be in UEFI mode. CSM = Compatibility System Module. Its role is to emulate an old bios prior to UEFI being introduced in 2009.
Thanks for replying. My motherboard is Asus rog Strix E wifi. You are right. With CSM disabled. My nvme shows in storage but not in the boot. Yes, i have windows boot manager under Boot Priority. With CSM on it will just show my USB flash drive that i use to install windows 10.

Here are the screenshots of my all storage devices.






that won't work then, it doesn't have a boot partition. Was there another drive in the PC when you installed win 10 on NVME? As it would appear to me win 10 has just added its boot details to the other install.

can you show a screenshot of disk management with all drives attached. Upload to an image sharing website and show link here.
Yes all my drives were attached when windows was installed.:(

My current Bios settings are.
Launch CSM = Enabled
Boot device control = UEFI and Legacy OPROM
Boot from network devices = UEFI only
Boot from storage devices = UEFI only
Boot from PCI-E = UEFI only

Under boot/secure boost OS type is set to Windows UEFI mode.
If i disable CSM my nvme doesn't show in boot section.
 
Last edited:

Colif

Win 10 Master
Moderator
i can tell the answer to - Did you have other drives attached when you installed to NVME? - is yes as the boot partition is on disk 1, D drive. System partition - Where PC is booting from.

NVME is booting off Disk 1. Which has to be MBR since it doesn't have an efi partition.

If you want to use UEFI boot on that PC you will want to start again.
remove all other drives when you install on NVME, that will stop windows repeating this. It was trying to be helpful, it saw a boot partition on D and used that instead of making one on Disk 0 like it should have.
 
Reactions: Mickey Sood

Colif

Win 10 Master
Moderator
what are the games? if they are steam games you can move them to H temporarily - https://www.howtogeek.com/269515/how-to-move-a-steam-game-to-another-drive-without-re-downloading-it/

To remove chance bios accidentally boots to it in future, it is likely a good idea to remove it. if it was just a mbr partition there might be a way to just delete it. Instead its a custom install with just 2 partitions and all the boot info is merged into a normal part. Was D drive ever windows?

you would need to use diskpart to delete it since its a system partition. Probably a good idea to do this after win 10 can boot off nvme without drive in pc. Or you won't be able to boot at all

Boot from installer
On screen after language choice, pick repair pc, not install
Pick troubleshoot
Pick advanced
Pick Command Prompt
Type diskpart and press enter
Type list disk and press enter

This will show the list of drives currently attached to PC, make note of the drive number of the drive you want to wipe

If Disk 1 is the drive you want to clear, type select 1) and press enter. A message will confirm it is selected
Warning: Diskpart Erase/Clean will permanently erase/destroy all data on the selected drive. Please be certain that you are erasing the correct disk.
Once you sure its right disk, type Clean and press enter
The Command Prompt window will display the message "DiskPart succeeded in cleaning the disk". Close out of the Command Prompt window by clicking the red X in the upper right hand corner.
 
Last edited:
Reactions: Mickey Sood
Nov 23, 2020
19
1
15
0
what are the games? if they are steam games you can move them to H temporarily - https://www.howtogeek.com/269515/how-to-move-a-steam-game-to-another-drive-without-re-downloading-it/

To remove chance bios accidentally boots to it in future, it is likely a good idea to remove it. if it was just a mbr partition there might be a way to just delete it. Instead its a custom install with just 2 partitions and all the boot info is merged into a normal part. Was D drive ever windows?
Yes, those are steam games and as well as quite a few from Epic games app. Thanks for the link.

Yes, i think D drive used to be a window before i bought my first SSD and installed fresh windows on it a few years ago. Since then i have only used that drive to dump softwares and other documents.

I will follow all the instructions that you mentioned for a fresh install and get back to you with the results.
 
Execute following commands from elevated command prompt. Regular command prompt will give error on last step.
(if you get any errors, then stop immediately)
diskpart
list disk
select disk 0
list partition
select partition x
(select 638GB partition, x=2 or x=3)​
shrink desired=500
create partition efi
format fs=fat32 quick
assign letter=M
exit
bcdboot C:\windows /s M:

Reboot into BIOS,
disable csm,
set windows Boot Manager as first in boot order.

Done.

How to get to elevated command prompt:
 
Nov 23, 2020
19
1
15
0
Execute following commands from elevated command prompt. Regular command prompt will give error on last step.
(if you get any errors, then stop immediately)
diskpart
list disk
select disk 0
list partition
select partition x
(select 638GB partition, x=2 or x=3)​
shrink desired=500
create partition efi
format fs=fat32 quick
assign letter=M
exit
bcdboot C:\windows /s M:

Reboot into BIOS,
disable csm,
set windows Boot Manager as first in boot order.

Done.

How to get to elevated command prompt:
I followed the steps.
'format fs=fat32 quick' didnt work. I followed rest of the steps. Disk management shows 500 mb healthy efi but after CSM disabled i still couldn't boot. My nvme doesn't show up in boot manager. I guess it didn't work because the efi partition doesn't have letter M assigned to it? what did i do wrong?

 
Last edited:
I followed the steps.
'format fs=fat32 quick' didnt work.
what was the error?
I followed rest of the steps. Disk management shows 500 mb healthy efi but after CSM disabled i still couldn't boot. My nvme doesn't show up in boot manager. I guess it didn't work because the efi partition doesn't have letter M assigned to it? what did i do wrong?
Format 500MB partition manually from Disk Management
Assign letter M: to 500MB partition and execute from elevated command prompt.
bcdboot C:\windows /s M:

NVME drive will not show in boot order. You have to select Windows Boot Manager as first boot entry.
 
Nov 23, 2020
19
1
15
0
what was the error?
Oh i dont remember it exactly but it was something along the lines of 'Windows was unable to complete the format'

Format 500MB partition manually from Disk Management
Assign letter M: to 500MB partition and execute from elevated command prompt.
bcdboot C:\windows /s M:

NVME drive will not show in boot order. You have to select Windows Boot Manager as first boot entry.
I managed to format and rename the 500 MB partition through minitool parition. And then used bcdboot C:\windows /s M:

But in disk management, it still won't show the change and the right click is greyed out. However, i can see it in mini tool partition and partition M is also visible in my devices and drives.




I disabled CSM and this is what i get





I had to enable it again in order to boot into windows.
 
Nov 23, 2020
19
1
15
0
And what are available choices under Boot Option #1 from above screenshot?
I'd suggest leaving only BOOT option #1 enabled and disable options #2,#3,#4


These are the available option. I disabled all except for 1.
Disabled CSM. On boot i get the same message 'the system can not find any bootable devices'

I guess fresh install is the only option then to get it working in UEFI mode?
 
Nov 23, 2020
19
1
15
0
I think - you still haven't turned off secure boot.

Turn it off and Windows Boot Manager boot option should become available.
I promise that's all there is in the secure boot section. I changed the OS type to 'Other OS' as you asked. Nothing else for me to disable.



The only other option available is key management and I have no idea what to do with it.

 
Nov 23, 2020
19
1
15
0
You can see it yourself - secure boot is still enabled.
Secure boot state - "user"

Read instructions to disable secure boot here:

Thank you. I followed the instructions and i get a secure boot state = 'setup' instead of disabled? i followed the guide exactly but i couldn't get to disable it.



 
Nov 23, 2020
19
1
15
0
i can tell the answer to - Did you have other drives attached when you installed to NVME? - is yes as the boot partition is on disk 1, D drive. System partition - Where PC is booting from.

NVME is booting off Disk 1. Which has to be MBR since it doesn't have an efi partition.

If you want to use UEFI boot on that PC you will want to start again.
remove all other drives when you install on NVME, that will stop windows repeating this. It was trying to be helpful, it saw a boot partition on D and used that instead of making one on Disk 0 like it should have.
After many failed attempts to disable secure boost I went ahead and did a fresh reinstall and used diskpart to format disk 1 with boot files. Thank you. I can boot in UEFI mode.
 

ASK THE COMMUNITY

TRENDING THREADS