Trying to Disable Secure Boot to install Linux

Aug 12, 2018
1
0
10
0
Hi guys!

Before I get going, I've googled this problem and come close to a solution, but not quite.

Motherboard: Asus Z87-Pro

I'm trying to install Solus distro on a brand new SSD; the PC I just installed the SSD in is running Windows 10 on a separate SSD.

I set up a USB drive to install Solus, but when trying to boot from the USB I get a message along the lines of: "To install this operating system you need to disable secure boot." My motherboard shows the Secure Boot options greyed out though, so I couldn't disable them.

After some Googling I found out that I could delete the security keys (I made a backup) and set a sys admin password, this would still leave the options greyed out, but show Secure Boot as "Disabled." Also, this would show PKs as "Unloaded."

I did these steps, only to find that I get the same message: "To install this operating system you need to disable secure boot." This is not the exact wording, if necessary I'll record the full message.

What I don't understand is, it says Secure Boot is disabled. I then set my BIOS to legacy mode, only to get the same message. I've spent at least 3 hours on this and I'm at a loss.

Any help would be greatly appreciated. I'm really excited to start my journey into Linux.

Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS