Question Trying to fix my 1050 Ti that stopped working ?

Apr 15, 2021
1
0
10
0
So I am a huge newbie when it comes to this so don't expect much from me. I bought a gtx 1050ti in early 2019 (February if I had to be precise) to put into my dell Inspiron my dad got me. I would have thought it would be good for that purpose since it didn't have a PSU port. and it worked very well for a while, the temperatures didn't seem to go too high and I didnt experience any stutters. Then it stopped displaying anything in early October (I didnt post here right away because I just assumed it was dead ). I don't remember updating anything around that time either so I'm pretty much clueless of what could have caused this. I don't really know what to do to diagnose it/fix it, any help would be much appreciated.

Link to the GPU I bought: https://www.gigabyte.com/Graphics-Card/GV-N105TD5-4GD#kf
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Include PSU: make, model, wattage, age condition.

= = = =

Lots of things you can do:

Try another known working video cable. Try other video outputs.

Manually download the GPU drivers via the manufacture's website. Reinstall and reconfigure.

Look in Reliability History for error codes and warnings that you associated with the GPU failure. Reliability History has a time line format that may prove very helpful.

Power down, unplug, open the case.

Clean out dust and debris.

Confirm by both sight and feel, that all cards, connectors, RAM, and jumpers are fully and firmly in place.
 

ASK THE COMMUNITY

TRENDING THREADS