Question Trying to get a Drobo FS to work on Winodws 10/11


Jan 27, 2015
I recently picked up a Drobo-FS from a small company that upgraded to newer NASs. Ive got the Drobo hooked up to my network and it has been assigned an IP address by the router. However when I launch the Drobo dashboard software it can never find the Drobo. If Im using Dashboard 2.6.4, which is what Drobos website has available to download for the FS model specifically, then it wont auto connect nor will it connect if I tell it to connect using the IP address assigned by the router. I tried an older version of dashboard (1.6.8) and it will not auto connect either and it does not have anywhere to input a manual IP address to connect to like 2.6.4 does.

Other things Ive tried:
Ive tried both versions of the dashboard on windows 10 and 11
Ive tried both versions of dashboard in compatibility mode and not in comp mode.
Tried installing SMBv1.0 per another post I saw online that recommended that to someone else.
If I type in \\ it seems to connect to the device although it only shows a "public" shared folder, Im assuming because the drive isnt set up. I can also ping the device.

If anyone has any suggestions Im all ears. I really dont want to have to shell out the money for a new NAS. TIA