Question Trying to revive old computer from 2005 but won't install or boot from /SDB (IDE hdd)

Hi folks.

Background story - feel free to read this boring stuff
I have this really old computer that have being in use for many years (ok not much lately). It have had a long and happy life, I've taken good care of it, even replaced a couple of capacitors on the mainboard that was getting blown about three years ago. After that It worked like a charm, and the last couple of years it have being running Ubuntu Mate 18.04.

Now I found it was time to install something more updated. Figured that none of Linux Mate or Cinnamon desktop editions was able to boot (to live desktop), maybe because of little RAM (just 2GB). However, I got both Mint XFCE, MX Linux XFCE and also Fedora 33 XFCE spin to boot to live desktop just fine.
So I draw the conclusion that I must have a distro that use XFCE in order for the computer being able to work.

Let's dig into details and HW
The only HDD is two really old IDE drives that is mounted on the first IDE channel and share the same cable.

From blkid on Linux Mint live desktop
mint@mint:~$ sudo blkid
/dev/mapper/ventoy: UUID="2021-01-03-18-37-02-00" LABEL="Linux Mint 20.1 Xfce 64-bit" TYPE="iso9660" PTUUID="3e172ebe" PTTYPE="dos"
/dev/sdc1: LABEL="Ventoy" UUID="7157b27b-4875-42f7-bc1d-2df81e9d4023" TYPE="ext4" PARTUUID="7a21466f-01"
/dev/sdc2: UUID="2021-01-03-18-37-02-00" LABEL="Linux Mint 20.1 Xfce 64-bit" TYPE="iso9660" PTUUID="3e172ebe" PTTYPE="dos"
/dev/loop0: TYPE="squashfs"
/dev/sdb: TYPE="promise_fasttrack_raid_member"
/dev/sda: PTUUID="f2cef2ce" PTTYPE="dos"
What I notice is that it repport sdb as "promise_fasttrack_raid_member" - weird.

Full hardware list - sudo inxi -Fxmz
mint@mint:~$ sudo inxi -Fxmz
  Kernel: 5.4.0-58-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
  Desktop: Xfce 4.14.2 Distro: Linux Mint 20.1 Ulyssa
  base: Ubuntu 20.04 focal
  Type: Desktop Mobo: DFI model: LP UT NF3 Utral-D serial: N/A BIOS: Phoenix
  v: 6.00 PG date: 07/11/2005
  RAM: total: 1.94 GiB used: 1.12 GiB (57.6%)
  Array-1: capacity: 16 GiB slots: 4 EC: None max module size: 4 GiB
  Device-1: A0 size: 512 MiB speed: type: Unknown
  Device-2: A1 size: 512 MiB speed: type: Unknown
  Device-3: A2 size: 512 MiB speed: type: Unknown
  Device-4: A3 size: 512 MiB speed: type: Unknown
  Topology: Dual Core model: AMD Athlon 64 X2 4400+ bits: 64 type: MCP
  arch: K8 rev.E rev: 2 L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 bogomips: 8842
  Speed: 2211 MHz min/max: N/A Core speeds (MHz): 1: 2211 2: 2211
  Device-1: NVIDIA G71 [GeForce 7800 GS] driver: nouveau v: kernel
  bus ID: 02:00.0
  Display: server: X.Org 1.20.8 driver: nouveau
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: NV47 v: 2.1 Mesa 20.0.8 direct render: Yes
  Device-1: NVIDIA nForce3 250Gb AC97 Audio vendor: DFI driver: snd_intel8x0
  v: kernel bus ID: 00:06.0
  Sound Server: ALSA v: k5.4.0-58-generic
  Device-1: NVIDIA CK8S Ethernet type: network bridge driver: forcedeth
  v: kernel port: e600 bus ID: 00:05.0
  IF: enp0s5 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 113.57 GiB used: 262.9 MiB (0.2%)
  ID-1: /dev/sda vendor: Hitachi model: IC25N030ATCS04-0 size: 27.95 GiB
  temp: 36 C
  ID-2: /dev/sdb vendor: Seagate model: ST360021A size: 55.90 GiB temp: 43 C
  ID-3: /dev/sdc type: USB model: USB Mass Storage Device size: 29.72 GiB
  ID-1: / size: 992.3 MiB used: 262.9 MiB (26.5%) fs: overlay
  source: ERR-102
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nouveau temp: 62 C
  Fan Speeds (RPM): N/A
  Processes: 184 Uptime: 21m Init: systemd runlevel: 5 Compilers: gcc: 9.3.0
  Shell: bash v: 5.0.17 inxi: 3.0.38
Also to mention - when I try to do any work using the live desktop, I don't experience any HW problems.

Neither of the HDD repports any issues on the smart. data (I need to boot live desktop in order to reveal here - when that said, MX Linux have a very nice tool for that). I also ran a HDD benchmark test on both HDD when I was on Linux Mint live desktop, both hdd seems to work just fine.

Problem 1 - to install Linux to the IDE slave drive
The installer begins just fine, I select "something else" for the advanced partition options. However - Linux Mint installer actually does not list /sdb in the drop down menu, So can't put / there.
That is weird.

Problem 2 - MX Linux won't boot from IDE slave drive
Thinking this may be an Mint/Ubuntu related Issue, I try again - with MX Linux (that runs just fine in live session on that computer).
Some days I went ahead installing MX Linux to sdb as I was able to do so from within MX installer.

The installer proceed, not making any errors as far I can see. That was a couple of days ago, getting late so I didn't bother trying to boot to test. That I did today.
What I mean with won't boot ?
  • The drive list up in bios as ok.
  • The ST360021A is listed as first in boot priority.
  • But when supposed to boot, the bios acts like there is no drive, or that the drive isn't bootable - proceeding to the last on the boot list, the pxe boot attemp (stops here, can't get further).
As it stand right now, I've the following suspicion of what can be the issue:
  • Ventoy issue. Yes I did use Ventoy in order to boot the ISO images because I can use full advantage of the space on a usb stick trying multiple distros without flashing the stick over again.
  • An actual issue with the ST360021A drive, despite it doesn't appear to be so by looking at S.M.A.R.T. data. The problem is that I was able to do a full benchmark on both drives and that the smart data repports both ok.
    • Possible sub issue : The fact the IDE slave was removed from an old laptop and have none pins to assign master/slave so that may pose an issue - despite the hdd is repported ok as slave in bios menu.
  • 3 fans on the same 3-pin fan adapter (project in project to increase air flow through dust filter). This work like a charm, the fans are small (6mm, max 200mA each) and the rpm repports good in bios.
  • The motherboard is actually so old that it's not fully supported by Linux kernel of current Linux releases.
What do you think of this? Can you think of something else that what I've listed above ?

Thanks in advance :D

rephrased so to clarify that the ide slave hdd is the 2.5' from an old laptop, and not the other way around.
Last edited:


The thing with old IDE/ATA drives is, that during boot up, BIOS doesn't look towards Slave drives at all. It only considers Master drive as bootable drive. And i think that this is the very issue what you're facing.

Testing it is easy:
  • Plug the drives around on the IDE cable, where current Slave sits on Master port. You could remove the current Master all together for testing.
  • Disable the current Master from BIOS, so when PC boots up, BIOS has only access to Slave drive, which it then considers as "Master" drive.
Btw, for good GNU/Linux distro, that works well on old hardware, look towards Lubuntu. I have Lubuntu 17.10 on my old Asus 701 laptop (from 2008) since it only has 512MB of RAM.
Reactions: Grobe
I've tried out a couple of things now:
  • Put the Seagate ST360021A on it's own PATA cable as single master (no change)
  • Using separate usb stick for Lnux Mint only - to see if it is a Ventoy issue - no change (i.e. Ventoy is not to blame)
  • Disconnect the Hitachi IC25N030ATCS04-0 drive
    • The installer seemingly have the /sda option in drop down menu, but the window (where manipulating partitions) are empty.
    • Attempting to add partitions make the installer to crash (maybe no wonder, it doesn't list up anyting on the drive anyway)
However - when I look back on the output from the blkid command, I notice that the disk are flagged with a promise raid signature. This is what I think the problem really are - remind me of this forum thread at

So now I have to find out how I can remove this promise raid signature from the hdd.

Actually I think I just found a web page that have a solution:
Reactions: Aeacus
Problem solved, can confirm that the raid signature on the hdd was the culprit.

Here is what I did this withing LM live desktop, I disconnected the Hitachi IC25N030ATCS04-0 (/sda in first post) while doing this.

About dmraid I found it ships with Linux Mint so no need to install. Here is from lsblk:
mint@mint:~$ lsblk
loop0    7:0    0  1.7G  1 loop /rofs
sda      8:0    0 55.9G  0 disk 
sdb      8:16   1  1.9G  0 disk 
├─sdb1   8:17   1  1.8G  0 part /cdrom
└─sdb2   8:18   1  3.9M  0 part 
sr0     11:0    1 1024M  0 rom
Seems that the hdd have being used in a stiped raid previously.
mint@mint:~$ sudo dmraid -r
/dev/sda: pdc, "pdc_ccdeiagf", stripe, ok, 117231345 sectors, data@ 0
I also followed this step in the tutorial, but I think I've misunderstand something. Not sure what to expect from this command.
mint@mint:~$ ls -R /dev/mapper
The commands to perform the removal of the raid signature
mint@mint:~$ DEVICE=/dev/sda
mint@mint:~$ sudo dmraid -r -E $DEVICE
Do you really want to erase "pdc" ondisk metadata on /dev/sda ? [y/n] :y
Hope this can help someone else that comes over an old computer and want to revive 🆒
Reactions: Aeacus
Jul 23, 2021
I will suggest MX Linux Xfce version as a distro for this old hardware, Lubuntu is not nearly as light as it was in the past.
If it struggles with that, then try it with the included Fluxbox or try the related antiX distro.