Question Trying to test my motherboard Rog Strix x570-e

Nov 18, 2020
2
0
10
0
Hi guys! I need your help.
I'm missing 2 vital components to properly test my motherboard:
  1. CPU (currently on back order: Ryzen 7 5800x)
  2. GPU (currently on pre-order: Radeon 6800xt)
The components I have:
  1. Mobo: ASUS Rog Strix x570-e
  2. RAM : Corsair Vengeance RGB Pro RGB 32Gb
  3. M.2 : WD Black SN750 NVMe
  4. PSU : ASUS Rog Strix 850G 850W
  5. Case : Fractral Design Define 7
  6. AIO : Cooler Master MasterLiquid ML360
I tried to test my motherboard with my available components are attached but I ran into problems:
A. The mobo rgb is working but all of the fans aren't (3 case fans, 1 AIO, and PSU fans are dead).
B. My RGB RAM isn't lighting up.
So I tried removing the mobo and test my PSU via the paperclip method. Result: 3 case fans are working and PSU fan working as well.

My question is do I really need to have a GPU and CPU for the fans and RAM to work? Or is this a sign of a defective mobo or my PSU (850W) isn't enough to power the whole system?

Thank you guys in advance for your help. It is my first time building a desktop and I appreciate whatever assistance you guys can give.
 
Nov 18, 2020
2
0
10
0
what are you testing? to light up the RAM and make the FANS spin? i know oyu wanna play with your new gear but it's useless without a gpu or cpu. why risk damaging it?
Yes, I'm trying to check if the rest of my components work. They are still on warranty but will expire in a couple weeks or so. Therefore, I decided to try and check what I could so if one of my components is defective I could have it replaced under warranty.
All of the components were suppose to arrive this week. However, due to the supply and demand my cpu and gpu hasn't arrived yet.
From what I understood you will not risk damaging it. A friend of mine said some mobo will simply not boot up without all the components.
 
Jan 16, 2021
1
0
10
0
Hi Thuspull,

have currently the same "issue" have to wait for my gpu and cpu.
Have also tried an old a10 -9700 apu which is not supportet. But havn't get it running...
Same behaviour as the one you have described. Have also ordered a second mobo to ensure that is not the issue.
So, have you get it running? or is it only working with a supported cpu?

Best RaketenPeter
 

ASK THE COMMUNITY

TRENDING THREADS