Question Two 8GB memory sticks not working after power cut

May 11, 2022
5
0
10
0
After the power cut my PC is not showing anything on the monitor. After few tinkering i found out that both of 8GB memory sticks are the problem so i installed two of my old 4GB ram's and the PC starts normally. but both of the 8GB Ram's are also working in my friends PC without any problem. i kept trying to put those 8GB sticks to my PC but soon as i do that there's not display coming. what could be the problem.

This is my old PC using mainly for office work:

Intel Core i5 4670K
Asus H81M-K (Updated to latest bios)
16GB DDR3 RAM (Two 8GB Apacer sticks)
500SSD, 4TB HDD
GTX 1050 Ti 4GB
Antec NX550 550W 80PLUS Bronze Power Supply
 
Last edited:

geofelt

Titan
Are both sticks from the same matched kit?
Ram is sold in kits for a reason.
A motherboard must manage all the ram using the same specs of voltage, cas and speed.
The internal workings are designed for the capacity of the kit.
Ram from the same vendor and part number can be made up of differing manufacturing components over time.
Some motherboards, can be very sensitive to this.
This is more difficult when more sticks are involved.
Ram must be matched for proper operation.

Try to
Run memtest86 or memtest86+
They boot from a usb stick and do not use windows.
You can download them here:
If you can run a full pass with NO errors, your ram should be ok.

Test one stick at a time, then both sticks if they test ok individually.

Try replacing the CR2032 button battery in your motherboard.
It might have degraded over time.
It is used to retain settings such as ram settings across power outages.
As a theory, you had adjusted ram settings to allow you to run and when the power went out, the motherboard reverted to default initial settings
 
May 11, 2022
5
0
10
0
Thank you for all the reply's, Yes i tried all these methods. but both 8GB sticks are not working in my motherboard anymore which is weird because I was using them for almost 2 years now. but its working on my friends pc with no issue
 
May 11, 2022
5
0
10
0
I used my friends mother board (ASUS H87-Plus) with all of my other accessories and the PC is starting with out any issue. after i put my motherboard back in same issue comes back only working with my old 4GB RAM's. its like the MB is not recognizing the 8GB sticks anymore
 

ASK THE COMMUNITY