Question Two New ADATA XPG GAMMIX S50 Lite SSDs died on new MSI Motar B660m wifi board!! Please give me some advice.

Mar 23, 2022
1
0
10
0
Please give me some advice.

On 17th March, I brought a new pc with this configuration,
Intel i5 12400
MSI Motar B660m Wifi
4x8Gb ADATA D50 3200 Ram
ADATA XPG GAMMIX S50 Lite NVMe 1TB SSD
Corsair CV650
This pc was built for only programming.
On 18th
First I installed Windows 10, doing some migration and reboots suddenly a blue screen arrived saying some hardware failed, like SSD, hard disk, etc.
The odd thing was normally windows just reboot, but it was not rebooting, so I forcefully switched off the PSU. After a few hours, the same thing happened, and I again switched off the PSU.
After setting up windows, I tried to dual boot Ubuntu.
Here also I forcefully switched off the PSU 1-2 times at installation time because Ubuntu was getting frozen (because I was using 3.0 USB and bugs).
After that, I installed a new kernel for some reason I again forcefully off the PSU and
bios can't detect S50 Lite NVMe anymore.
***If the M.2 SSD is connected, bios taking a long time to open, without it opening instantly

Today:
After replacing it today again tried to install windows and Ubuntu,
No blue screen when installing windows, but when installing Ubuntu I did forcefully power off 3 times, but this time not from PSU, by holding the power button for 4-5 sec. Again, bios can't detect S50 Lite NVMe.

Same as before if plugin bios is taking a long time to open.

Causes:
  1. forcefully power cut can kill NVMe, I know data can get corrupted, but physical damage from power cut?
  2. PSU is defective
  3. Mobo is defective
  4. Both M.2 was defective, there is a slight possibility because I replaced it from the same store, maybe they got a defective batch
Give me some clue, experts. Currently, I am getting a headache because of this :(
 

ASK THE COMMUNITY

TRENDING THREADS