Question Typing Lag New System

DreamsUnderStars

Prominent
Jun 7, 2020
11
0
510
0
Ok so I have had a new system for a couple months now. The only thing from my old system installed in the graphics driver.
I'm using Waterfox right now and don't have any other browsers installed. This only happens when the broswer is running for too long it seems. And only on certain websites like forums (swords of legends online), facebook and reddit. My keyboard is wireless, it's been charged up. I put the USB on an extension cord so it's closer to the keyboard and it still lag occaisionally.

I have checked for malware, viruses, updated all the drivers I could, windows updated the other day. Is this just a crappy weak keyboard?

Keyboard is an Arteck 2.4ghz wireless.
Win 10 Pro
MSI B450 Tomahawk Max
AMD Ryzen 5 3600
16 gigs of ram
AMD RX 560
 
does Arteck offer any control software for the keyboard?
if so, there could be response time parameters that can be altered.

was it also "lagging" when not using the USB extension?
try a couple different USB ports and if it continues it may just be crapping out.

Is this just a crappy weak keyboard?
i've never heard of the brand.

check to see what warranty they offer. if they're willing to send a shipping label or prepaid box, go for an RMA.
if they're jerks about it, we'll all just remember Arteck as something to avoid from now on.
 

DreamsUnderStars

Prominent
Jun 7, 2020
11
0
510
0
I've tried all the USB ports.
As for RMA I thought about that, but I modified the keys (painted them for visibility) so they would just blame lag issue on me or say I voided the warranty. I'd never heard of arteck either until I went looking for a new rechargeable keyboard.
 

ASK THE COMMUNITY

TRENDING THREADS