• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

[SOLVED] UEFI/Bios doesn't detect dvd

odehart

Distinguished
Jan 5, 2010
18
0
18,510
0
After several trips to have my pc worked on I gave up. Always had problems. My last trip the shop installed W10 Home. I decided to go back to Pro and found I couldn't boot from any cd/dvd or usb drive [all of which turn on and appear when in W10]. In bios I discovered there were no options in boot order except MS boot manager. Think I'm not upset? No more using that shop. Because boot manager has only MS boot manager I can't install Pro. There are no bootable devices other than C:\. How do I get the dvd/cd to appear in boot manager. Below is my system info:


Tech Support Guy System Info Utility version 1.0.0.4
OS Version: Microsoft Windows 10 Home, 64 bit
Processor: AMD Ryzen 3 2200G with Radeon Vega Graphics, AMD64 Family 23 Model 17 Stepping 0
Processor Count: 4
RAM: 16304 Mb
Graphics Card: NVIDIA GeForce GT 710, 1024 Mb
Hard Drives: C: 476 GB (209 GB Free); F: 931 GB (871 GB Free);
Motherboard: ASUSTeK COMPUTER INC., ROG STRIX B450-F GAMING
Antivirus: System Shield, Disabled
 
your OS shouldn't affect the boards' ability to detect devices when booting or in the BIOS.
my first thought would be there's some kind of security settings in the BIOS disabling external devices from booting.

i would first load optimized defaults and see if anything changes.
if not, flash\reflash the BIOS to the latest version and check again.

it's also possible that using the onboard boot manager you could direct the system to load from DVD or USB.
try F8 when posting.

there's also a chance that using Settings > Update & Security > Recovery > Advanced Startup would allow you to direct Windows to boot directly to a device.
 
your OS shouldn't affect the boards' ability to detect devices when booting or in the BIOS.
my first thought would be there's some kind of security settings in the BIOS disabling external devices from booting.

i would first load optimized defaults and see if anything changes.
if not, flash\reflash the BIOS to the latest version and check again.

it's also possible that using the onboard boot manager you could direct the system to load from DVD or USB.
try F8 when posting.

there's also a chance that using Settings > Update & Security > Recovery > Advanced Startup would allow you to direct Windows to boot directly to a device.
 
Also, if your system came with windows 10 home originally, what you need to do is try to change your key to your pro key and it should upgrade it for you. The installer will pick up the key that is stored in the bios.

If your pro key will not work, there are some generic windows 10 pro keys that are posted online. Get one of those, disconnect from the internet and tell it to use that key. It should upgrade your version of windows to pro.

Once you do that, your system will show like it’s not activated. Then try to again change product keys, this time to your genuine windows 10 product key after connecting to internet. It should then see it and activate. I’ve had to use this trick work in situations where a system was bought at retail and came with windows 10 home. We have a windows volume license we can purchase licenses through as needed, so we’ve had to use that method only a few times. But it boils down to if the system came with home edition that is the version it will try to use when you install windows 10. So reinstalling may not do what you think it will.
 

odehart

Distinguished
Jan 5, 2010
18
0
18,510
0
your OS shouldn't affect the boards' ability to detect devices when booting or in the BIOS.
my first thought would be there's some kind of security settings in the BIOS disabling external devices from booting.

i would first load optimized defaults and see if anything changes.
if not, flash\reflash the BIOS to the latest version and check again.

it's also possible that using the onboard boot manager you could direct the system to load from DVD or USB.
try F8 when posting.

there's also a chance that using Settings > Update & Security > Recovery > Advanced Startup would allow you to direct Windows to boot directly to a device.
Optimizing defaults did indeed work.
 

ASK THE COMMUNITY