UEFI (BIOS) on Wrong Monitor (NVidia Graphics)

Agrajag

Distinguished
May 24, 2005
18
0
18,510
0
I had an Asus Maximus VI motherboard with three monitors attached. Windows 10 OS.

1. An HP (primary)
2. An Acer (side monitor)
3. A home theater screen (Sony) that runs through a Yamaha receiver.

Everything worked as I wanted with the BIOS on the old motherboard showing up on the primary (HP) display. I then upgraded the PC and ended up with an Asus Maximus X motherboard, but now the displays are not acting as I'd hoped. The video card hasn't changed between setups. It's a Gigabyte (Nvidia) 1070.

I had so much trouble that I bought cables to get each monitor to end at Display Port (the HP is natively HDMI, the Acer is DVI and the theater his HDMI). So now I can at least move them about on the card itself. However, no matter what I do the "BIOS" appears on the theater screen which is a real pain as it's often turned off and in another room away from the PC.

Nothing I do can seem to get this to appear on my primary HP display. Once Windows loads everything is fine, but prior to that, no luck. I've tried all sorts of settings including CSM enabled, disabled, etc. Nothing seems to impact it.

My friend has an MSI board and they have a feature to read the Win10 setup to ID which monitor is primary. I don't see any such option for Asus.
 

Agrajag

Distinguished
May 24, 2005
18
0
18,510
0
The monitors are all connected via DP at this point. I've tried moving every monitor to every port on the graphics card. The only thing that happens is that Windows has a harder time dealing with wallpaper. That's it. If I boot with JUST HP connected (no cables for the other cards in) then the bios appears on the HP without any issue.

I should mention that monitor "1" (HP) and "3" (theater) are set to mirror. This also seems to make a difference. If I don't mirror them then the BIOS appears on the HP.

 

RobCrezz

Titan
Herald


OK try that. Then add the other monitors after windows has booted. make sure you have the primary set. Then shut down, and boot up again and see if keeps the settings.
 

Agrajag

Distinguished
May 24, 2005
18
0
18,510
0


Sadly I've been there and done that. That's how I started with the latest install of Windows 10. Only the HP connected. It had no knowledge of the other two until I was fully set up. I then added them in (first the Acer) and then the theater.

 

gaaah

Honorable
Sep 13, 2013
106
1
10,710
6
For 3 or 4 years, ever since I put in my GTX 1060, the BIOS (or more correctly, UEFI) would show up only on a secondary monitor. When it first happened I researched for about a whole day to get it to display on my primary, but to no avail, so I suffered with it as it was. If I wanted to get into the UEFI, I had to always make sure my secondary (an HDTV) was on. I'm a retired programmer who's been building and programming PC's since 1984. The config seemed burned into the hardware.

I'm glad to report that it's fixed now, but in the most unexpected way: I was doing a security check of my system and noticed "secure boot" in my UEFI was off, so I turned it on. You can also see this setting in "System Information" while in Windows 10. On my GigaByte GA-X99UD5, it took a few restarts to enable it --one to get into "user mode" and one to turn on secure boot with the default keys, but after I did, voila, UEFI was displaying on my primary.
One other setting I turned on was Windows 8/10 WHQL drivers, which is a much less drastic change that you may want to try first.

Sorry, I haven't the slightest idea how or why this worked, I'm just reporting that it did.
 
Reactions: NotSoFunnyClown

Agrajag

Distinguished
May 24, 2005
18
0
18,510
0


Thanks. I'll give it a try. It seems obvious to me that this is something MS and the board manufacturers need to have a chat about. More and more people are using multiple monitors and the current level of support is pretty anemic.

 

gaaah

Honorable
Sep 13, 2013
106
1
10,710
6
I should add a little about my setup --unchanged since I got my GTX 1060: My GTX 1060 has one DisplayPort and one HDMI. The DisplayPort runs to my primary (a 4K monitor) and the HDMI runs to my 4K TV. No adapters used or needed.
 

alainch

Prominent
Oct 23, 2017
5
0
510
0
it's nice when people forget (or don't care) to report back !

Ask community, get help, forget to thanks or to say something useful to community.

Alain
 
May 17, 2019
1
0
10
0
I'm glad to report that it's fixed now, but in the most unexpected way: I was doing a security check of my system and noticed "secure boot" in my UEFI was off, so I turned it on. You can also see this setting in "System Information" while in Windows 10. On my GigaByte GA-X99UD5, it took a few restarts to enable it --one to get into "user mode" and one to turn on secure boot with the default keys, but after I did, voila, UEFI was displaying on my primary.
I've just signed up here to reply :D
I've got the same problem with my setup. Secure boot was already enabled on my board but that didn't fixed the problem.

But... i've fixed it! There is a boot option in my UEFI called "CSM-Mode" (Compatibility Support Module). By default it was set to "enabled". I've then changed it to "auto" and there you go... bootscreen is now on my screen i've set as primary in windows and as a little side effect the resolution in the UEFI and boot menu just increased :)

I hope that could help someone :)
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS