UEFI CPU Multiplier does not apply? Used to work.

TehPenguin

Reputable
May 12, 2016
700
0
5,060
35
Hello dear Tom's Hardware Community,

I've been away for a while and so I hope I still remember all the rules that apply to posting.


I haven't used my PC very heavily for a while so I cannot point out which Windows update has caused this, or preceded the issue.
My CPU went back to its stock configuration and I cannot seem to be able to overclock it via UEFI as I used to be able to.
The odd thing is that all the settings in UEFI stayed the same and the "Target" clock is as I set it up almost 2 years ago.

Everything else works. XMP Profile for the memory is working, I can change the base clock no problem but no matter what number I punch into the multiplier it just reverts back to default upon system boot. Now the settings are as I have set them once I go back to UEFI and everything seems to be in order.
No errors on or before boot.

A while back I just set the multiplier to 40, Voltage to Auto and was a happy camper, pretty much.

i7-6800k target 4.0GHz
Asus STRIX X99 Gaming
latest BIOS and Windows Update
 

Meadowlion

Commendable
Feb 27, 2017
30
0
1,530
0
Try saving these settings as a user default. Then reset UEFI back to defaults reboot and try changing just the core multiplier. Sometimes weird settings interfere with this.
 

TehPenguin

Reputable
May 12, 2016
700
0
5,060
35


It was. I disabled SpeedStep, not sure about Turboboost. I disabled Turbo Mode? Either way all that changed is the stock speed. It wen't down to 3.4GHz from the 3.6GHz that the IntelSpeedStep was enforcing I assume.

EDIT: Nope. It's the TurboMode that gives the extra 200MHz. So SpeedStep only lowers the clock as per definition.
 

DavidM012

Reputable
Feb 4, 2016
378
29
4,840
17
If you have the latest bios I'd report it back to Asus probably only they could help. There have been bios issues on the strix it may be a question of whether they are on top of it yet.
 

Dragos Manea

Admirable
Dont bother is a bug from windows, only way to gain your OC back is if you have an mcupdate_genuineINTEL.dll file since the oc was working or get one older then the 1803 version of windows. Main culprit is KB4100347 for 1803 (windows 10 1809 it has integrated in it so you cannot manually uninstall and block this update.) If you wait untill tonight (in about 10 hours) i will give you a file to replace your non-working dll.
Also another solution would be (this is what i did) to manually inject all microcodes updates into your bios and force install bios by usb force install (not inside the bios but using crash free bios function of your motherboard). You decide which you want and i will help you step by step to do it.
 

TehPenguin

Reputable
May 12, 2016
700
0
5,060
35


Yeah I was eyeballing windows pretty hard on that one. Thanks for the confirmation.
I would be really grateful if you could provide the working DLL. Waiting is not a problem.
 

Dragos Manea

Admirable
Here it is, download this zip, to replace the dll file you must take ownership and modify control of the file, i included a step by step image guide how to do this, after you complete the steps you can copy and replace the dll i gave you.

https://www.dropbox.com/s/phowp1dc9weyhwn/Steps%20to%20fix%20OC%20on%20BR-E.zip?dl=0

P.S. For got mention the culprit file is in "C:\Windows\System32\mcupdate_GenuineIntel.dll" , this si the file you must take ownership and replace.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS