Question (UGH) Old Dell Desktop won't boot.

Rodan1337

Commendable
May 23, 2017
21
0
1,520
2
I have this old Dell Inspiron 545 Desktop from 2009 or so. It ended up dying in about 2012, and I haven't really cared enough to fix it until now. It's for a dumb reason as well, nostalgia. I want to see what programs I installed on it about 7 years ago and see how well it's doing. So I decided to seek help, after hours of searching forums. Forums helped narrow down these issues, but provided no answers. I'll list the specs, even though I don't think they're important...

CPU: Intel Pentium 2.66ghz (I think 2 cores)
GPU: Integrated (2009 haha)
RAM: 6gb (It says 6400U, but I'm used to it measured in MHz so I don't know, it doesn't give me anything I can understand)
Hard-Drive: exists.

Some useful info pertaining to the issue:
  • No light is coming from the power button that I could see even after taking off the front panel.
  • Green Light underneath the power cord's connection to the PSU, not sure about this but I believe it's registering that the PSU is receiving power from the wall, ruling out the power cord and outlet as an issue.
  • The motherboard's amber light is on, which I'm not 100% sure what this means either, but it's receiving power I'm pretty sure.
  • Just to double check, I self-tested the PSU by putting the green and black wires together with the paper-clip and the PSU and it's fan booted perfectly, which was actually a very sweet moment for me, as nothing in this PC had booted since 2012.
  • The BIOS battery has never been replaced, and as I'm typing this it's sitting here in front of me "airing out".
  • I tried to diagnose whether the power button was working or not, so I took a screwdriver and pushed it against the part that connects to the motherboard, but nothing registered and it didn't start up.
Overall, the power outlet, power cord, power supply, power connection to the motherboard, and the power on/off button have been ruled out. I've heard of the BIOS battery preventing the system from starting. My system, from what I remember, seemed to die after the power went out. According to my uneducated observation, I think possibly the motherboard or CPU may be fried, however, I truly have no idea.

I've stayed up all night trying to diagnose it, and I've come so far, but still no luck. Also, I noticed a little red thing underneath the green light, it seems to be a button and says 115 on one end, and maybe looks like I can push it in on the other end. Too afraid to try. Doing some research on it.

Any help appreciated!
 
Last edited:

hang-the-9

Titan
Moderator
Without trying out different parts all you have are educated guesses. No one will point to a single thing for sure. Could be a bad power supply, may need a new BIOS battery, could be motherboard is bad.

Do you want to get this thing working specifically or just want to copy files from it? For that age system if you need it to run something, you are better off finding a working model and move your drive into it rather than buying parts.
 

ASK THE COMMUNITY