Question Unable To Access SSHD

Feb 23, 2020
1
0
10
0
I had an ASUS laptop with an internal Seagate Firecuda 1TB 1U7172-500 SSHD. (The drive is in decent condition and was functioning just fine at the time of removal. There's only just under 400GB of used storage on it.) I took it out as I had bought a new computer from Digital Storm and I was attempting to copy the files from this SSHD onto my new PC via SATA to USB.

The first time I did this, it came up fine. I tried accessing files from my profile on the drive and I was given an access denied. I went to look how to fix that and next thing I know, the PC stopped seeing the SSHD. I tried unplugging and plugging it back in over and over and it either doesn't load or loads and freezes when I try to interact with it.

I tried plugging it into my other, much lighter in specs laptop. It killed it. 2 Computers later and the same story, neither of them can seem to allow me to do anything with this SSHD.

I can't format it or anything. If I click on it it freezes my whole computer, alot of times making it black and it has to refresh itself. I even dual booted Linux alongside Windows because I was told by a friend that Windows sees it as a bootable medium and it's confusing the system.

Using Linux did not work, this is not the case. I need the files off this SSHD, failure is not an option here. Please help?

There were a couple ideas I had in mind, them being:
  1. Turn the internal SSHD into an external one.
  2. Buy the exact same laptop, just switch out the new SSHD for this one and then transfer the files from Laptop to PC.
I wanted to see if any of you had any ideas as to what's going on and if there's a better idea than the two I have, because I'm positive there is. Especially seeing as they're solutions I came up when I don't even know what the problem is.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS