• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Unable to boot computer bios nor OS

May 25, 2020
I have an ASUS Prime Z370-A motherboard. The computer has been functional for over a year with no recent hardware changes. The problem first occurred when a bluescreen error restarted the computer. Since then, when attempting to start the computer the monitor displays nothing, not booting the bios. The motherboard POST State LEDs clear the CPU, DRAM, VGA, and BOOT checks. I've already tried reducing to a single RAM stick in each slot with each stick. I have also tried reseting the CMOS by removing the battery for an hour and a half. I have also tried using a completely different PSU that is known to work. The problem remains after those attempts at a soultion. I'm completely at a loss as to what has gone wrong. Any insight on how to get the computer functional again is much appreciated.