Question Unable to Boot from Any Drive After Enabling RAID on Gigabyte GA-Z270X-UD3

Dizzy49

Distinguished
Jun 21, 2011
34
1
18,535
0
I have an existing machine running Windows 10 that I added two NVMe drives to.
I updated the BIOS on the mobo, and created a RAID in EZ Raid in the BIOS.
As soon as I did, I am no longer able to boot from my other (the OS) drive.

I tried to follow the instructions here: How to: Change SATA Modes After Windows Installation however, it has instructions for Win 7 and 8, not 10
  1. If currently installed, uninstall your RAID or AHCI SATA driver (for intel, intel rapid storage technology)
  2. Basically open msconfig -> boot tab -> check safe boot -> restart
  3. Go into UEFI/BIOS and set SATA mode to which ever one you want
  4. Boot up into windows safe mode
  5. Open msconfig again -> under the main menu tab (general) click the normal startup circle - > restart
  6. Your system should boot into windows fine and you can install your AHCI or RAID driver.
I booted to BIOS and set the SATA mode back to AHCI
I booted to Windows and set MS Config to Safe Mode
I booted back into BIOS, and enabled RAID again
Set up the RAID volume with the 2 NVMe drives, and I couldn't boot to Windows (seemed kind of stupid to me)

I set the RST setting to Enable Legacy OPROM or something like that. That allowed me to boot to windows.
I then installed the Intel Rapid Storage drivers. I can now see it when the system boots.
However, with the Legacy option enabled, it can't see the new NVMe drives. If I disable it, it sees the drives, but then I can't boot from my other drive again.
I tried to set the SATA mode back to AHCI and when I do it will not boot at all.

I'm kind of at a loss here. That post was from 2012, has Microsoft never addressed this issue in nearly 10 years?! It should NOT be this hard to create a RAID after you have installed Windows!
I had no idea it was going to be this hard, I would have just made a stiped volume in windows if I knew what a PITA this was going to be!

HELP!
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS