Question Unable to boot from M.2 NVMe drive ?

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Dec 8, 2022
35
0
30
0
Try to set
Fast Boot to disabled,
Boot Device control - UEFI and legacy.
Save and reboot.

so did that and booted from usb, selected install on drive 0 and waited. Windows installer counted down to reboot when done. I still do not see the drive as bootable or in the boot list. This is what I see if I open up the media tool and select install again. Gotta be close lol. Thank you again for all the help, I really appreciate it
 
Dec 8, 2022
35
0
30
0
After install is done, you have to remove install media and boot from internal drive.
You do not run install again.
Oh I only went back into it so you could see the change after installing to the drive. Just removed the usb and rebooted, it only goes to bios. Still not seeing the drive as bootable or in the boot list. It’s so strange… the only thing I’ve done since this started that got it to show in the boot list was to have rst on, but it’s always been the only drive in this pc so idk why. And it with rst on trying to boot I was getting the windows.efi.

if there are any other settings or any info/pics you need let me know. Wish I had another m.2 to try. I’ve heard people talking about clearing cmos after some similar kinds of problems, any point in trying that? I tried the screwdriver to the 2 jumpers method but don’t think it worked. Didn’t pop out the battery since it’s under the gpu and it’s a bitch to get it out of this case
 
Dec 8, 2022
35
0
30
0
RST has to be off.
And you can't change this setting after OS is installed.

Set first boot device to Windows Boot Manager.
No worries, I haven’t touched it since the other day. Since you started working with me on this I haven’t done anything other than what you recommended, so all settings should be right. Still nothing as a bootable device though. Nothing in boot list, then when I go to advanced and boot it’s empty.
I’ve read someone said Intel Platform Trust Technology setting caused their board to not recognize nvme… worth trying to disable? I see it enabled currently
 
Windows is installed in UEFI mode. Looks good.

Execute following:
diskpart
list disk
select disk 0
list partition
select partition 1
(select 100MB bootloader partition)​
assign letter=H
exit
bcdboot c:\windows /s H: /f UEFI

Last message should be "Boot files created successfully".
Show command output.
 
Dec 8, 2022
35
0
30
0
Windows is installed in UEFI mode. Looks good.

Execute following:
diskpart
list disk
select disk 0
list partition
select partition 1
(select 100MB bootloader partition)​
assign letter=H
exit
bcdboot c:\windows /s H: /f UEFI

Last message should be "Boot files created successfully".
Show command output.

all set. Try booting now or anything else needed first?
 
Dec 8, 2022
35
0
30
0
Windows is installed in UEFI mode. Looks good.

Execute following:
diskpart
list disk
select disk 0
list partition
select partition 1
(select 100MB bootloader partition)​
assign letter=H
exit
bcdboot c:\windows /s H: /f UEFI

Last message should be "Boot files created successfully".
Show command output.
Tried removing usb and rebooting after the last pic I sent, still not in boot list 😭
 
Dec 8, 2022
35
0
30
0
In BIOS
Boot/Secure Boot/OS Type - set to Other OS.

And show screenshot with available boot priority settings.
Secure boot was set to other os already, I sent those options and boot priority empty. In case it’s worth mentioning, at one point before I posted on here I followed a step to clear secure boot keys and load defaults. After doing that I set bios to all defaults. That was something I tried before you started working with me in this, might not matter but just wanted to throw that in.
 
Dec 8, 2022
35
0
30
0
When I look up the issue I see some things about disabling secure boot to be able to get into boot option priorities… not sure if that is a good idea or not so will leave things as is until I hear back from you
 
Dec 8, 2022
35
0
30
0
You can try changing
Boot from storage devices to UEFI
Boot from PCIE devices to UEFI.
Tried that and no change unfortunately. Can this be m.2 hardware failure even though we could install windows on it? Also strange because we moved it to another slot and no change. I can’t imagine what I did to cause this… slight cpu over clock and everything was good. Went in bios in hopes to get it to stop power throttling and somehow ended up here. If there’s anything else you recommend I’m happy to try. Thanks for all the help and time spent on this so far. Worst case I can buy a new m.2 but would hate to have the same issue and it turns out to be bios config lol
 
Dec 8, 2022
35
0
30
0
If you don't know, what you changed in BIOS, then
load safe defaults.
I’ve restored to defaults with f5 while in bios, is that the same thing or is there another way that’s recommended? I’m guessing with the pre build they made some adjustments, my cpu came over locked a bit so not sure if bios was changed when I got it
 
Dec 8, 2022
35
0
30
0
If you don't know, what you changed in BIOS, then
load safe defaults.
Just reset cmos with jumpers, confirmed settings changes in bios, definitely reset. Still not seeing my drive, still greyed out for boot option priorities and override. Looks like it disabled csm, enabled secure boot and fast boot… when I click “nvme controller and drive information,” the two options “nvme configuration,” and “no nvme device found,” are both greyed out still. Sata set ahci currently
 

ASK THE COMMUNITY

TRENDING THREADS