[SOLVED] Unable to connect router via pppoe but my pc can connect

Oct 19, 2019

When I dial up my BSNL FTTH connection from my pc using username and password, it connects within few seconds, but when I try doing the same from my router (so that more people can connect to my router), I am not able to do so, it fails to connect everytime with an error "Timed out waiting for PADS", but sometimes router successfully connects in PPPoE mode.. like 1 in 100 times. But the remaining 99 times I get the error. When dialling via PC, I never got an error yet and have connected within few seconds.
I tried also cloning MAC address of my PC into the router but it didnt work. Also, if my router by chance gets a successful connection established, it loses the connection on router restart and then again throws in the error.

Can somebody help me with this please ?

Router : TP Link Archer C50 v4
Modem : Nokia Siemens H640V-25E


Do you have the User Guide/Manuals for the modem and router?





Verify that the above links are correct for your modem and router.

Simplified Network line diagram:

ISP ---> Modem ---> Router --->Wired devices and ~~> wireless devices.

In your case the modem is actually a combination modem and router.

You need to disable the Nokia's router functions and let the Nokia serve strictly as a modem. Then let the TP-Link router perform all of the router functions.

And all network devices then connect to the router.

Read through the modem and router User Guides. Plan out the necessary connections, the corresponding configurations, and then set it all up accordingly.

Get the resulting network to work with just one wired PC connected to the router. Then add one wireless PC to the router.

That should give you a basic sense of how to add other wired and wireless devices to the network.

Again all being directly wired to the router or directly making a wireless connection.

There should be no need to clone MAC addresses.