[SOLVED] Unable to connect to wired ethernet

madsvags

Commendable
Dec 31, 2018
9
0
1,510
0
Hello,

I recently noticed that I was connected to wireless instead of wired internet. I don't know when it happened, but as a result I ended up with doing a network reset. This removed everything, and now I'm unable to find my ethernet adaptor/driver anywhere (Device manager, Network connections). I tried to download LAN Driver From Acer's website, where I end up on Realtek Ethernet Controller Driver - InstallShield Wizard. Trying to download this driver results in this error code: The Realtek Network Controller was not found. If Deep Sleep Mode is enabled Please Plug the Cable."

How do I download ethernet driver for my computer?
I have an Acer Nitro N50-600 computer.
Serial number: DGE0MEQ010820000DD1800.

I really don't know what to do at this point. I even factory reset my computer, but I still do not have an ethernet driver.
Tried to troubleshoot this now for 2 hours, but nothing works. Especially when most fixes revolves around Device Manager, but I do not have any ethernet driver on Device Manager.
Would really appreciate any suggestions on how to fix this. Thanks :))
 

Wolfshadw

Titan
Moderator
If this is a Windows system:

Open Device Manager
Expand the Network Adapters tree.

Do you see "Realtek PCIe GbE Family Controller"?

If yes, right-click and select properties. On the General Tab, what does it say under Device Status?
If no, right-click on Network Adapters and select Scan for Hardware Changes.
Then check to see if the Realtek PCIe GbE Family Controller appears.

If it appears, then you should be able to use it.
If not, then it's possible that the port has failed.

-Wolf sends
 

ASK THE COMMUNITY