• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

[SOLVED] Unable to find AHCI and IDE mode in Dell Inspiron 620s

Sagar_20

Reputable
Jun 29, 2016
863
89
5,090
20
I'm going to install windows in my new SSD, however my pc is running in IDE mode so i want to convert it from IDE to AHCI mode.

I have found a way to convert it with windows installed however i'm not able to find that option in the BIOS. Some days ago, that option was available but it has disappeared now.

I have no idea what's causing this. Somebody help.

My PC is currently updated to the latest bios called MS-A10 dated 19/12/2013.

On some forums i see that this motherboard doesn't natively support AHCI but some people are able to use it on this board.

Can somebody guide me how to mod the BIOS?
 
Last edited:

Sagar_20

Reputable
Jun 29, 2016
863
89
5,090
20
Ok guys i don't think i can get the solution here. I myself figured it out.

This method works 100% for the Dell Optiplex 390 and the Dell Inspiron 620s

Both use H61 chipset that does support the AHCI mode but i guess for compatibility with older S/W and H/W, they decided not to unlock the configuration modes in their latest Bios A10. [which is now 6 years old]

You don't need to download and mess with the BIOS editor.

(1) Just download the latest official update MS-A10 as well as it's edited BIN File MS-A10_AHCI.
(2) Now force run the original MS-10 by typing in it's address followed by " /forceit" in cmd with admin privileges. This will instantly run the file without any warning and give you the option to update.
(3) But don't click on update yet.
(4) Now go to the temp folder by typing %temp% in either run bar or the windows explorer.
(5) There you will find a folder named MS-A10 inside which there will be a bat file "MS-A10.BIN" 4096 KB in size.
(6) What you want to do is just replace that file from the temp folder with the downloaded one. [after renaming it as the original file name]
(7) Finally click the update button and reboot.

On reboot, repeatedly press the F2 key until the BIOS appears. Now you'll be able to see the config modes like IDE, AHCI and RAID, but wait.

One more thing. After you boot into the Windows go to run bar and type in regedit.

Then locate this directory:
Computer > HKEY_LOCAL_MACHINE > SYSTEM > services > msahci
Now click on the msachi folder and from the right, double click on "Start" and edit the value from 3 to zero and on next boot change IDE to AHCI.

Now let the computer boot. After some time you'll see a msg that your device is ready to use. You can also check it from device management.

Good luck

---------------------------------------------------------------------------------------------------------------
For Windows 10, you need to change a few directory by changing from 3 to to 0 (zero)?
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAV\StartOverride
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride)
 

ASK THE COMMUNITY

TRENDING THREADS