Question Unable to port forward specified ports

Feb 12, 2019
So, I'm unable to host game server but can host webserver without problems. Any ideas what I'm doing wrong ?

OS: Windows 10 (Home)
Modem: Arris TG2492s
NAT: RouteWithNat

So far tried:
  • Windows Firewall: disabled
  • DMZ: enabled
  • Router firewall: disabled
  • Allowed KFServer.exe via windows firewall.
Extra details
  • No extra antivirus etc. softwares (only windows defender and it's firewall)
  • Have restarted computer and modem (unplug from wall, wait for 30 seconds)
  • ISP informs they should not be blocking these ports, answer found at their support forums
I can host webserver (using XAMPP), so far successfully on ports 80, 8081 and 742. Which means I am able to port forward different ports. Others (which are not in my network) are able to see server using my public (WAN) IP.

TCPView for apache webserver

TCPView for game server:

I don't see any errors when launching game server and it is visible within game server browser (to me , at least), can also join and play. Lan mode is not enabled on server, so it should be visible to others.

Necessary ports are listed at:

Port forwards:
Last edited:
The first step is to use the DMZ option in your router and see if that works. This eliminates strange issues with port forwarding rules. I would remove all the port forwarding rules to be sure the things that you say currently work continue to work under the DMZ mode.

If you have issue with it set to DMZ mode then it is most likely the server that has something configured wrong. If it works with DMZ mode then it is something strange with the port forwarding rules.

If you really get stuck you can load wireshark on the server. It can be a massive amount of data so run as little network as possible when you are capturing. Wireshark will show all packets that arrive at your machine including packets that are later blocked by the firewall. You will know for sure if the packets are coming in or something else is preventing them from getting to your server.