Question Unable to turn on h170m-itx/ac

May 15, 2019
2
0
10
0
Hello everyone,

I have an ASRock h170m-itx/ac which for the last few weeks hasn't been wanting to turn on. I'll give a chronology of issues/actions:

  • Had PC about a year, bought secondhand from someone who used it for LANs etc
  • About 3-4 weeks ago had issue where SSD not detected, so changed ports on mobo and had no issues booting
  • several days later PC would not turn on after being shut down. Tried a different power supply cable and made no difference. Can hear electric hum from PSU so (I think) power isn't an issue
  • housemate suggested removing/resetting headers, this worked.
  • for last 2-3 weeks PC not turn on after power down, resetting headers worked 80% of time to boot it up. Sometimes had to do several times for result
  • PC runs fine when once I get it going
  • Resetting headers now does not work. Have tried switching power/reset and trying to boot with reset, not working/never worked. Also tried the screwdriver short but also unresponsive, but never worked from the first time I had this issue.
Any help greatly appreciated. I'm not too tech savvy but I'll try my best to answer/reply to what I can. Also tried searching forums but on mobile so it didn't go too well.

TIA everyone
 
May 15, 2019
2
0
10
0
Borrow another power supply.
I've tried borrowing one but no one I know has a spare. Apart from forking out for a new one do you have any suggestions about another issue it could be?
Appreciate the time it took you to reply, cheers mate
 

ASK THE COMMUNITY

TRENDING THREADS