Unable to uncheck Hide Protected System Files

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

For some reason I am unable to uncheck the 'Hide Protected System Files' in
the Tools View Tab. I need to gain access to these files as during a scan of
my hard drive with my anti-virus software a potential threat was found which
I need to remove manually. This option was previously available to me, so
either the registry has become corrupted or a virus has done this.

Please any assistance you can give would be greatly appreciated.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

Well what happens when you try. If it's not there you need to talk to your system administrator.

--
----------------------------------------------------------
http://www.uscricket.com
"gooders" <gooders@discussions.microsoft.com> wrote in message news:CF9916F6-C0C5-43C4-A2BC-C7B413B9F5F3@microsoft.com...
> For some reason I am unable to uncheck the 'Hide Protected System Files' in
> the Tools View Tab. I need to gain access to these files as during a scan of
> my hard drive with my anti-virus software a potential threat was found which
> I need to remove manually. This option was previously available to me, so
> either the registry has become corrupted or a virus has done this.
>
> Please any assistance you can give would be greatly appreciated.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

The option is there and currently flagged. When I click it to unflag it,
nothing happens, it remains checked. This is a personal laptop and I am the
system administrator.

"David Candy" wrote:

> Well what happens when you try. If it's not there you need to talk to your system administrator.
>
> --
> ----------------------------------------------------------
> http://www.uscricket.com
> "gooders" <gooders@discussions.microsoft.com> wrote in message news:CF9916F6-C0C5-43C4-A2BC-C7B413B9F5F3@microsoft.com...
> > For some reason I am unable to uncheck the 'Hide Protected System Files' in
> > the Tools View Tab. I need to gain access to these files as during a scan of
> > my hard drive with my anti-virus software a potential threat was found which
> > I need to remove manually. This option was previously available to me, so
> > either the registry has become corrupted or a virus has done this.
> >
> > Please any assistance you can give would be greatly appreciated.
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

Are you able to uncheck the other options? IOW, if this problem is seen only with that particular option (all other options work fine), open Registry Editor and navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden

Post the key here.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"gooders" <gooders@discussions.microsoft.com> wrote in message news:9C3368E7-38DE-4068-8EB3-0FC4DBE695B9@microsoft.com...
The option is there and currently flagged. When I click it to unflag it,
nothing happens, it remains checked. This is a personal laptop and I am the
system administrator.

"David Candy" wrote:

> Well what happens when you try. If it's not there you need to talk to your system administrator.
>
> --
> ----------------------------------------------------------
> http://www.uscricket.com
> "gooders" <gooders@discussions.microsoft.com> wrote in message news:CF9916F6-C0C5-43C4-A2BC-C7B413B9F5F3@microsoft.com...
> > For some reason I am unable to uncheck the 'Hide Protected System Files' in
> > the Tools View Tab. I need to gain access to these files as during a scan of
> > my hard drive with my anti-virus software a potential threat was found which
> > I need to remove manually. This option was previously available to me, so
> > either the registry has become corrupted or a virus has done this.
> >
> > Please any assistance you can give would be greatly appreciated.
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

Yes, I am able to check and uncheck all the other options, it's just this key
that's causing me problems.

The registry details you asked for are as follows:

(Default) REG_SZ (value not set)
CheckedValue REG_DWORD 0x00000000 (0)
DefaultValue REG_DWORD 0x00000000 (0)

HelpID REG_SZ shell.hlp#51103
HKeyRoot REG_DWORD 0x80000001 (2147483649)
RegPath REG_SZ
Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Text REG_SZ @shell32.dll,-30508
Type REG_SZ checkbox
UncheckedValue REG_DWORD 0x00000001 (1)

ValueName REG_SZ ShowSuperHidden
WarningIfNotDefault REG_SZ @shell32.dll,-28964


The Policy folder and DontShowSuperHidden folder are both empty with no
values set.

Thank you for your assistance


"Ramesh [MVP]" wrote:

> Are you able to uncheck the other options? IOW, if this problem is seen only with that particular option (all other options work fine), open Registry Editor and navigate to:
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden
>
> Post the key here.
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "gooders" <gooders@discussions.microsoft.com> wrote in message news:9C3368E7-38DE-4068-8EB3-0FC4DBE695B9@microsoft.com...
> The option is there and currently flagged. When I click it to unflag it,
> nothing happens, it remains checked. This is a personal laptop and I am the
> system administrator.
>
> "David Candy" wrote:
>
> > Well what happens when you try. If it's not there you need to talk to your system administrator.
> >
> > --
> > ----------------------------------------------------------
> > http://www.uscricket.com
> > "gooders" <gooders@discussions.microsoft.com> wrote in message news:CF9916F6-C0C5-43C4-A2BC-C7B413B9F5F3@microsoft.com...
> > > For some reason I am unable to uncheck the 'Hide Protected System Files' in
> > > the Tools View Tab. I need to gain access to these files as during a scan of
> > > my hard drive with my anti-virus software a potential threat was found which
> > > I need to remove manually. This option was previously available to me, so
> > > either the registry has become corrupted or a virus has done this.
> > >
> > > Please any assistance you can give would be greatly appreciated.
> >
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

Same here. But, I get a dialog box once I uncheck the "Hide protected Operating System......"

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"gooders" <gooders@discussions.microsoft.com> wrote in message news:9BE64B4B-DB90-460E-AE59-5898C85FD8D1@microsoft.com...
Yes, I am able to check and uncheck all the other options, it's just this key
that's causing me problems.

The registry details you asked for are as follows:

(Default) REG_SZ (value not set)
CheckedValue REG_DWORD 0x00000000 (0)
DefaultValue REG_DWORD 0x00000000 (0)

HelpID REG_SZ shell.hlp#51103
HKeyRoot REG_DWORD 0x80000001 (2147483649)
RegPath REG_SZ
Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Text REG_SZ @shell32.dll,-30508
Type REG_SZ checkbox
UncheckedValue REG_DWORD 0x00000001 (1)

ValueName REG_SZ ShowSuperHidden
WarningIfNotDefault REG_SZ @shell32.dll,-28964


The Policy folder and DontShowSuperHidden folder are both empty with no
values set.

Thank you for your assistance

<snip>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

Sorry, I don't understand your response. I am unable to uncheck that one box
therefore, I don't get the dialog box popping up warning me that I've chosen
to show system files and I am unable to see the hidden files.

"Ramesh [MVP]" wrote:

> Same here. But, I get a dialog box once I uncheck the "Hide protected Operating System......"
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "gooders" <gooders@discussions.microsoft.com> wrote in message news:9BE64B4B-DB90-460E-AE59-5898C85FD8D1@microsoft.com...
> Yes, I am able to check and uncheck all the other options, it's just this key
> that's causing me problems.
>
> The registry details you asked for are as follows:
>
> (Default) REG_SZ (value not set)
> CheckedValue REG_DWORD 0x00000000 (0)
> DefaultValue REG_DWORD 0x00000000 (0)
>
> HelpID REG_SZ shell.hlp#51103
> HKeyRoot REG_DWORD 0x80000001 (2147483649)
> RegPath REG_SZ
> Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
>
> Text REG_SZ @shell32.dll,-30508
> Type REG_SZ checkbox
> UncheckedValue REG_DWORD 0x00000001 (1)
>
> ValueName REG_SZ ShowSuperHidden
> WarningIfNotDefault REG_SZ @shell32.dll,-28964
>
>
> The Policy folder and DontShowSuperHidden folder are both empty with no
> values set.
>
> Thank you for your assistance
>
> <snip>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

The registry values seems OK, but not sure why this happens. Will look into this. Meanwhile you can try this:

Rename the value "WarningIfNotDefault" to "-WarningIfNotDefault".
Close Folder Options and re-open
Try unchecking the Hide protected Operating System......" option again.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"gooders" <gooders@discussions.microsoft.com> wrote in message news:69BB6120-BC9E-47D1-8532-FA83634DB889@microsoft.com...
Sorry, I don't understand your response. I am unable to uncheck that one box
therefore, I don't get the dialog box popping up warning me that I've chosen
to show system files and I am unable to see the hidden files.

"Ramesh [MVP]" wrote:

> Same here. But, I get a dialog box once I uncheck the "Hide protected Operating System......"
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "gooders" <gooders@discussions.microsoft.com> wrote in message news:9BE64B4B-DB90-460E-AE59-5898C85FD8D1@microsoft.com...
> Yes, I am able to check and uncheck all the other options, it's just this key
> that's causing me problems.
>
> The registry details you asked for are as follows:
>
> (Default) REG_SZ (value not set)
> CheckedValue REG_DWORD 0x00000000 (0)
> DefaultValue REG_DWORD 0x00000000 (0)
>
> HelpID REG_SZ shell.hlp#51103
> HKeyRoot REG_DWORD 0x80000001 (2147483649)
> RegPath REG_SZ
> Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
>
> Text REG_SZ @shell32.dll,-30508
> Type REG_SZ checkbox
> UncheckedValue REG_DWORD 0x00000001 (1)
>
> ValueName REG_SZ ShowSuperHidden
> WarningIfNotDefault REG_SZ @shell32.dll,-28964
>
>
> The Policy folder and DontShowSuperHidden folder are both empty with no
> values set.
>
> Thank you for your assistance
>
> <snip>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

Ramesh,

The renaming has worked. I can now check and uncheck the box, although I
don't get the warning message. The important thing is I can now gain access
to my hidden files.

Thank you very much for your speedy assistance and resolution.

Gooders

"Ramesh [MVP]" wrote:

> The registry values seems OK, but not sure why this happens. Will look into this. Meanwhile you can try this:
>
> Rename the value "WarningIfNotDefault" to "-WarningIfNotDefault".
> Close Folder Options and re-open
> Try unchecking the Hide protected Operating System......" option again.
>
> --
> Ramesh, Microsoft MVP
> Windows XP Shell/User
> http://windowsxp.mvps.org
>
>
> "gooders" <gooders@discussions.microsoft.com> wrote in message news:69BB6120-BC9E-47D1-8532-FA83634DB889@microsoft.com...
> Sorry, I don't understand your response. I am unable to uncheck that one box
> therefore, I don't get the dialog box popping up warning me that I've chosen
> to show system files and I am unable to see the hidden files.
>
> "Ramesh [MVP]" wrote:
>
> > Same here. But, I get a dialog box once I uncheck the "Hide protected Operating System......"
> >
> > --
> > Ramesh, Microsoft MVP
> > Windows XP Shell/User
> > http://windowsxp.mvps.org
> >
> >
> > "gooders" <gooders@discussions.microsoft.com> wrote in message news:9BE64B4B-DB90-460E-AE59-5898C85FD8D1@microsoft.com...
> > Yes, I am able to check and uncheck all the other options, it's just this key
> > that's causing me problems.
> >
> > The registry details you asked for are as follows:
> >
> > (Default) REG_SZ (value not set)
> > CheckedValue REG_DWORD 0x00000000 (0)
> > DefaultValue REG_DWORD 0x00000000 (0)
> >
> > HelpID REG_SZ shell.hlp#51103
> > HKeyRoot REG_DWORD 0x80000001 (2147483649)
> > RegPath REG_SZ
> > Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
> >
> > Text REG_SZ @shell32.dll,-30508
> > Type REG_SZ checkbox
> > UncheckedValue REG_DWORD 0x00000001 (1)
> >
> > ValueName REG_SZ ShowSuperHidden
> > WarningIfNotDefault REG_SZ @shell32.dll,-28964
> >
> >
> > The Policy folder and DontShowSuperHidden folder are both empty with no
> > values set.
> >
> > Thank you for your assistance
> >
> > <snip>
> >
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

That's great! Then there is something wrong while explorer calls this resource "@shell32.dll,-28964". You should try running SFC /Scannow with the XP CD in.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"gooders" <gooders@discussions.microsoft.com> wrote in message news:0B153D07-7171-499E-A908-78A45DE3DB12@microsoft.com...
Ramesh,

The renaming has worked. I can now check and uncheck the box, although I
don't get the warning message. The important thing is I can now gain access
to my hidden files.

Thank you very much for your speedy assistance and resolution.

Gooders

"Ramesh [MVP]" wrote:

> The registry values seems OK, but not sure why this happens. Will look into this. Meanwhile you can try this:
>
> Rename the value "WarningIfNotDefault" to "-WarningIfNotDefault".
> Close Folder Options and re-open
> Try unchecking the Hide protected Operating System......" option again.
<snip>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.customize (More info?)

I can't think of any reason why you can't check it. Does using the keyboard work? (space (un/)selects).

I've confirmed the policy hides it and doesn't make it unclickable. Setting no write security on the key that menu is built from affects nothing. I didn't set no security on where that setting is stored cause everything else in that dialog stores in the same place and you'd get an error on leaving the dialog, unlike where it's built from which each item is close by but in seperate storage.

So I wouldn't worry my pretty little head but just bypass the dialog

Type regedit in Start Run
Go to
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
and add as a DWord or edit an existing one
ShowSuperHidden
and set it to 1

Then have another look at the dialog.
--
----------------------------------------------------------
http://www.uscricket.com
"gooders" <gooders@discussions.microsoft.com> wrote in message news:69BB6120-BC9E-47D1-8532-FA83634DB889@microsoft.com...
> Sorry, I don't understand your response. I am unable to uncheck that one box
> therefore, I don't get the dialog box popping up warning me that I've chosen
> to show system files and I am unable to see the hidden files.
>
> "Ramesh [MVP]" wrote:
>
>> Same here. But, I get a dialog box once I uncheck the "Hide protected Operating System......"
>>
>> --
>> Ramesh, Microsoft MVP
>> Windows XP Shell/User
>> http://windowsxp.mvps.org
>>
>>
>> "gooders" <gooders@discussions.microsoft.com> wrote in message news:9BE64B4B-DB90-460E-AE59-5898C85FD8D1@microsoft.com...
>> Yes, I am able to check and uncheck all the other options, it's just this key
>> that's causing me problems.
>>
>> The registry details you asked for are as follows:
>>
>> (Default) REG_SZ (value not set)
>> CheckedValue REG_DWORD 0x00000000 (0)
>> DefaultValue REG_DWORD 0x00000000 (0)
>>
>> HelpID REG_SZ shell.hlp#51103
>> HKeyRoot REG_DWORD 0x80000001 (2147483649)
>> RegPath REG_SZ
>> Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
>>
>> Text REG_SZ @shell32.dll,-30508
>> Type REG_SZ checkbox
>> UncheckedValue REG_DWORD 0x00000001 (1)
>>
>> ValueName REG_SZ ShowSuperHidden
>> WarningIfNotDefault REG_SZ @shell32.dll,-28964
>>
>>
>> The Policy folder and DontShowSuperHidden folder are both empty with no
>> values set.
>>
>> Thank you for your assistance
>>
>> <snip>
>>