Question unbricking rx 470 mining graphics card

Mar 1, 2020
22
1
15
0
I'm having trouble getting display from my igd, internal graphics device. Whenever I plug in my external graphics card, my internal device will shut off. I need to have both working at the same time for me to be able to reflash it. Any ideas? I only have one pcie so I can't use two external graphics at the same time.
 
Mar 1, 2020
22
1
15
0
Indeed.. It doesnt have that feature. I suppose i'm left with getting a motherboard with two pcie's slots then? One for the rx 470 and the other for the working display.
 

Phaaze88

Polypheme
Ambassador
Why? Your RX 470 is dead.
That's one of the risks you take with gpu vbios flashing. If the card had a dual bios feature, you could've avoided this by:
-turning the PC off
-flipping the switching to the working bios
-turning the PC on, logging in
-flipping the switch back to the borked bios
-downloading and installing the original bios to overwrite the borked one
Voila, done.
 
Mar 1, 2020
22
1
15
0
That line of reasoning wouldn't apply, I don't have a dual switch bios. Regardless I've made a new discovery, which is that it works on a friends motherboard I know.
Update-
I'm not completely 'Boned' (your words) haha, there is still some hope. I managed to be able to reflash the bios using friends motherboard. But whenever I hook it up to my motherboard it doesn't work. The post doesn't display on startup so it's not a driver issue, I could try reinstalling the OS, but I'm doubtful that would do anything, and my motherboard works with my other gpu (GeForce gtx650), so everything is working fine. The safest assumption is that it's a compatibility issue because it's just my motherboard and my new GPU that aren't working together. I just don't have much to go on for proper troubleshooting. Any tech savants out there can help me out?
 

ASK THE COMMUNITY