[SOLVED] Unexpected low fps on Destiny 2, help

Jun 10, 2020
26
0
40
1
Hello, I was looking for games and I found Destiny 2, I liked it, I saw the requirements and I see that i was going to run smoothly and I started playing, but I see that I have very low fps, it seems strange to me because I had seen in previous benchmarks with the same components I, who in max settings have to go +85, 95 fps in any scenario, while I don't go above 50 frames, sometimes even 30 fps, I don't think it's a hardware problem because my setup is almost new (6 months) and never had performance issues with other games

I have a GTX 1650 Super and a I3 9100F, 16 GB RAM 2666mhz, Corsair CV Series 550W 80Plus Bronze

in the screenshot you can see that i am in game while its running in 30 fps, i have opened the HWINFO to check everything, the temps are fine, but the cpu is almost always in 100% of his usage, i dont think that the cpu is not enough because i played more demanding games that Destiny 2.

P.S.: I dont have a FPS cap in the game, in the v-sync is off, max settings, it should be run more smooth.

View: https://imgur.com/uTJLaqn
 
Jun 10, 2020
26
0
40
1
Run userbenchmark again with Google chrome closed as well as any other programs like Steam, Blizzard app, Origin and suspend your virus scanner for the duration of the test if possible. Post the results page.

If lowering the resolution in game does not increase fps, it probably means you are CPU bound. You may still have programs running in the background or you have malware. You also had the issue of your CPU not even running at it's base frequency of 3.6GHz or even boosting properly when you ran the benchmark before, which suggest there may be an issue with bios settings or with Windows. You can try resetting your bios to defaults to see if it fixes anything, but you may need to make note of a few settings to restore them later, like boot drive priority and possibly CPU features being enabled or disabled.
Well first of all, I was looking at many solutions and I came across the solution to disable HPET, I did it and, omg it worked incredibly, I play at 70fps up, normally 75-85fps, the minimum I got to see was 65fps and the maximum was in underground areas that I got at 120fps (all this in graphics at maximum) and now everything works very well fortunately. a very smooth experience.
View: https://imgur.com/a/9NAZR9N



Now answering you, here is the test link: https://www.userbenchmark.com/UserRun/34340502
I close everything possible to be effective, and I repeat that the RAM may not operate as expected because its frequency is limited by the CPU Also, I don't think i have malware because that game was the only time something like this happened to me. And the problem that the CPU does not reach its base frequency, I don't really understand the reason very well, I'm going to take into account what you told me to test the BIOS with its default settings to see if it solves the CPU, anyways, I am going to buy another new CPU because it would be good to update the setup, that's all

If I do not get to answer more here, thank you very much everyone for your intentions to help me!
 
Jun 10, 2020
26
0
40
1
Go to userbenchmark.com and run the test. Link the results here after.
Here it is.
https://www.userbenchmark.com/UserRun/34269015
now i realize it says i have 30% on background cpu but i looked at task manager and it is not true and i dont have like malware or something like that
View: https://imgur.com/a/rL5ueyv


I did 3 tests and all 3 told me the same thing, I closed all unnecessary applications and i restarted the cpu for the test
 
Here it is.
https://www.userbenchmark.com/UserRun/34269015
now i realize it says i have 30% on background cpu but i looked at task manager and it is not true and i dont have like malware or something like that

I did 3 tests and all 3 told me the same thing, I closed all unnecessary applications and i restarted the cpu for the test
I'm guessing you didn't close Chrome, which you don't want to be running during a benchmark because it's using system resources. That might also be the issue when playing Destiny 2.
 
2 issues!

#1: CPU not even hitting base frequency.

What are temps while gaming? What cooler do you have? What case fans? On latest BIOS? All drivers up-to-date?

#2: RAM not operating at correct speed. Are they installed in correct slots?(I see you only have 2 slots) Make sure to enable XMP. Are you on latest BIOS.
 
2 issues!

#1: CPU not even hitting base frequency.

What are temps while gaming? What cooler do you have? What case fans? On latest BIOS? All drivers up-to-date?

#2: RAM not operating at correct speed. Are they installed in correct slots?(I see you only have 2 slots) Make sure to enable XMP. Are you on latest BIOS.
I'm going to guess the OP's CPU is thermal throttling because the all core turbo boost should be something like 3.8GHz with the stock cooler (although I'm not even sure there is an all core boost with that i3) and the i3-9100f is limiting the ram to 2400. https://ark.intel.com/content/www/us/en/ark/products/190886/intel-core-i3-9100f-processor-6m-cache-up-to-4-20-ghz.html
 
Jun 10, 2020
26
0
40
1
2 issues!

#1: CPU not even hitting base frequency.

What are temps while gaming? What cooler do you have? What case fans? On latest BIOS? All drivers up-to-date?

#2: RAM not operating at correct speed. Are they installed in correct slots?(I see you only have 2 slots) Make sure to enable XMP. Are you on latest BIOS.
Okay
1- You can see that the temps are good of both components in the first screenshot that i uploaded, GPU Max temps are 60 degrees and the CPU max 65 degrees, the cpu maybe a little hot while gaming because im not using a cooler, its the intel stock cooler, i have 4 case fans, 3 in the front and 1 in the back, i have the second latest BIOS version (1401), the latest is 1605, should i update it?, updating bios can be dangerous, or not?

Latest Windows version, but whoops, now i see that im not having the latest drivers on the GPU, i will update the drivers of the GPU and i will going to let you know everything

2- The RAM is not operating in 2666mhz because the CPU is limiting that frequency, the I3 9100F only supports up to 2400mhz, i will see if i have activated the XMP.

Update: I did not have xmp activated, now I activated it, that, and the updated gpu drivers, now I will see how everything is going

Update 2: Still the same thing, 35-45fps all scenarios.
View: https://imgur.com/a/u2Sd2Jz
 
Last edited:
IMPORTANT UPDATE: i test everything by lowing all the graphics and i still get the same amount of frames on Highest or on Lowest lol, it is so weird, i set the render resolution on 25% (the lowest), and i still have the same frames.


30-45 fps even on lowest.
Run userbenchmark again with Google chrome closed as well as any other programs like Steam, Blizzard app, Origin and suspend your virus scanner for the duration of the test if possible. Post the results page.

If lowering the resolution in game does not increase fps, it probably means you are CPU bound. You may still have programs running in the background or you have malware. You also had the issue of your CPU not even running at it's base frequency of 3.6GHz or even boosting properly when you ran the benchmark before, which suggest there may be an issue with bios settings or with Windows. You can try resetting your bios to defaults to see if it fixes anything, but you may need to make note of a few settings to restore them later, like boot drive priority and possibly CPU features being enabled or disabled.
 
Jun 10, 2020
26
0
40
1
Run userbenchmark again with Google chrome closed as well as any other programs like Steam, Blizzard app, Origin and suspend your virus scanner for the duration of the test if possible. Post the results page.

If lowering the resolution in game does not increase fps, it probably means you are CPU bound. You may still have programs running in the background or you have malware. You also had the issue of your CPU not even running at it's base frequency of 3.6GHz or even boosting properly when you ran the benchmark before, which suggest there may be an issue with bios settings or with Windows. You can try resetting your bios to defaults to see if it fixes anything, but you may need to make note of a few settings to restore them later, like boot drive priority and possibly CPU features being enabled or disabled.
Well first of all, I was looking at many solutions and I came across the solution to disable HPET, I did it and, omg it worked incredibly, I play at 70fps up, normally 75-85fps, the minimum I got to see was 65fps and the maximum was in underground areas that I got at 120fps (all this in graphics at maximum) and now everything works very well fortunately. a very smooth experience.
View: https://imgur.com/a/9NAZR9N



Now answering you, here is the test link: https://www.userbenchmark.com/UserRun/34340502
I close everything possible to be effective, and I repeat that the RAM may not operate as expected because its frequency is limited by the CPU Also, I don't think i have malware because that game was the only time something like this happened to me. And the problem that the CPU does not reach its base frequency, I don't really understand the reason very well, I'm going to take into account what you told me to test the BIOS with its default settings to see if it solves the CPU, anyways, I am going to buy another new CPU because it would be good to update the setup, that's all

If I do not get to answer more here, thank you very much everyone for your intentions to help me!
 

ASK THE COMMUNITY

TRENDING THREADS