Unique screen flicker problem

amar7

Distinguished
Oct 11, 2011
8
0
18,510
Hi guys, Please check this video link (http://vimeo.com/22231224)

I am so upset with my system because of this. I can't even pretend what I should change.. Don't know where the actual problem is..

My configuration:
ASUS - M4A785T-M
AMD X2 3.2 GHz blak-edition
corsair and kingstone (2 + 2 GB DDR3)
Segate 500 + 500 GB
corsair VX-450-W

Hope you guys can understand whats going on and help me to solve this!
 

Pilk

Distinguished
Jan 6, 2010
519
0
19,010
Hi Amar there could be a few things with regards to your problem GRA, Screen, Memory, Motherboard or CPU we will need to use process of elimination for this. A couple of questions, does this only happen when coding? does i happen when running other tasks or applications maybe even different script? Have you tried an alternative screen? Also how long round about does it take for the flickering to start and effect?
 

amar7

Distinguished
Oct 11, 2011
8
0
18,510
Hi, I was facing this problem from long back.. I posted in some forum and many people said its the problem of PSU. So I changed it. I had a coolermaster PSU (the one which comes default with the ELITE cabinet). I took a new one (corsair VX-450-W). I don't use graphics card.

But still the problem persist! Then somebody told its heating problem.. I opened the processor and applied coolermaster heat sink paste nicely. After that the problem got solved! I never saw screen flickers. But then after 7-10 days I realized that the screen flicker is still there but the frequency became very less. Like once every 5 days or so.

No this doesn't happen only when I am coding. It happens sometimes when I do processor intensive stuff like coping huge amount of data to an external USB drive, etc. Also not all the time. Right now the frequency of flickering is very less. If I open NetBeans for 20 times, it "might" happen only once.

The time span of the flickering is not constant. Sometimes it comes only for 1-2 seconds. And sometimes its so lengthy and bad, that I just power-off my system.

No I have not tested it in a different monitor. But will do it next time. I have a dual display setup, so as soon as the flickering start, I will switch on my secondary monitor.
 

Pilk

Distinguished
Jan 6, 2010
519
0
19,010
Awesome thats great and what about your HDD have run CKDSK on them just to check there consistency? What speed are the drives? Do you have S.M.A.R.T. enabled in BIOS? Does it give any errors? Its unlikely its the drives however you utilizing a lot of disk interaction with what you have described to me. Does also sound like a CPU issue as well as you stated so lets look at those two for now.
 

amar7

Distinguished
Oct 11, 2011
8
0
18,510
Hi,
Can you tell me how to run CKDSK? I am using Ubuntu 11.04 64-bit
Also, I searched for SMART in my bios settings, but couldn't find.

Here are few more info and new video link:
I wanted to video-record the flickering so that I can show you, and gave lot of stress to my system. I started VirtualBox (win XP and 7 both together). Then net beans and also few instances of firefox and chrome. Oh! Also GIMP! But there was no flickering! The system was so stressed that almost all the resources were being used above 95%! After not seeing any flickering, I restarted my system.. Then suddenly I saw little bit of flickering and vanished after 10-15 seconds.

Then I switched on both the displays and started watching videos and other regular stuff. And after a while, I saw the flickering (in both the displays) again and recorded it! here is the video link http://vimeo.com/30470203


Also I am facing another problem (maybe these two are related):
When I purchased my system almost 7-8 months back, I had only 2 GB RAM (Kingston). After using it for almost 3 months I thought of adding another 2GB. So bought a corsair value RAM 2GB DDR3. When I inserted that in to my CPU, the computer didn't start. I mean the fans inside the CPU is running, power light is glowing, but the BIOS screen is not coming. Nothing is coming in the display actually, the monitor goes to "Power saving mode".. Then I gave the new RAM to service center for a replacement. Then when I got a new RAM replaced, and connected that to my system, it worked properly any my system got booted!

Again, two weeks back I bought another corsair Value select RAM of 4GB. I connected it and got the same "Power saving mode" problem. Got it replaced again, STILL the same "Power saving mode" problem!!! Finally I gave up and kept that new 4GB RAM aside.. I researched the net and got some info like I have power problem in my RAM slots.. I need a configuration like 8-8-8-21 or something like that. I never tried since I don't understand these things much.

Now the funny part, Sometimes (like every 2 days) I get the "Power saving mode" problem (my system has only 2 + 2 GB RAM now)!! I simply take one RAM out and put it in another slot, and my system boots! God knows whats happening...

Hope you can figure out something!

Thanks
 

amar7

Distinguished
Oct 11, 2011
8
0
18,510
Hi Pilk,

I checked the list.. But here is one more info you should know:
I was having total 4 GB RAM. 2GB Kingston and 2GB Corsair. I thought that the problem is for corsair RAMs. So I removed the 2GB Corsair Value select RAM and kept only the 2GB Kingston. In-fact, when I bought this computer, I had only 2GB Kingston RAM. Guess what, even now I am getting the same flickering!

Now I am thinking its the problem of the motherboard... What do you think?

Model number of my Corsair RAMs:
4GB stick: CMV4GX3M1A333C9
2GB stick: VS2GB1333D3DR

The kingston is inside, so can't see the model number right now. But, The shop from where I purchased my PC, gives the kingston RAM to every one who purchase Intel / AMD system, until and unless the customer asks for something different or PC configuration is too high..

Thanks
 

Pilk

Distinguished
Jan 6, 2010
519
0
19,010
Kingston is generally the most widely compatible ram an that is why they would use it most of there systems, i would think the KIngston to give less issues then the Corsair Generally speaking. Have you moved the KIngston dimm around on the dimm ports of the motherboard? instead of having it in slot 1 move it to slot 2,3 or 4?
 

amar7

Distinguished
Oct 11, 2011
8
0
18,510
Yeah I have done that many times... Same problem... I think this mostly happens when the CPU is stressed (but not always). Now the question is, is it because processor or m-board..
 

Pilk

Distinguished
Jan 6, 2010
519
0
19,010
would recommend that you get memtest and run a memory test for about 5 passes which will probably take half a day to run but will give you a clear indication of whats going on with the ram, just put the 1 dimm the original 2GB as all of the dims do give issues as you say. Heres a link to the program you should run on the memory.

http://www.memtest.org/
 

amar7

Distinguished
Oct 11, 2011
8
0
18,510
Hi Plik,

I have found the actual problem :) I brought some of my friend's RAMs and checked if the problem exists with those too or not. And, yes, what ever RAM I put, I am getting the flickering.

Then I installed a CPU temperature meter and checked how its changing. I noticed that whenever the temperature is going high, its flickering.. For last few days, the flickering was so extensive that I couldn't even open the browser!

Then I thought of giving one last try with the heat-sink. When I opened the CPU cooling fan and checked, I saw the thermal paste has dried completely.. i cleaned if applied a new layer of thermal paste. Then after switching on the system, I didn't see any flickering. Its almost 2 days now, still no flickering, also the temperature is moderate..

I also bought an expensive thermal-paste and re-applied it. The computer is working fine now :) AMD is having bad reputation in India only because of heating! And, yes, I am one of the victim!

Also, about the 8GB RAM, I have given that to the corsair service center, and they will courier me a new one by this weekend. Lets see what happens when I connect that! Will definitely update this thread!

Thanks a lot !!
 

Pilk

Distinguished
Jan 6, 2010
519
0
19,010
Awesome man am very happy for you glad everything is sorted. Also if you thinking of a aftermarket cooler for the future look at the Corsair H60 Hydro series they are amazing i use one of these myself. =)
 

truegenius

Distinguished
BANNED


No display can be only due to dust in ram slots.
I too face this same problem of no display at least one time in a year, when this happens i just clean it up (complete cabinet especially ram) to resolve it.
for flickering part of the issue high temperature and bad cooling can be the cause