Question Unique TR Legend Crash/Freeze after Intro Video

Sep 4, 2022
Update: Turns out after I uninstalled the Asus "bloatwares" (Armory Crate, for example), the game then goes into the title screen. I thought by clean booting (turning off non-Window services upon reboot) that it would have done that, thus making me think the bloatwares weren't the culprit. Since these services and process are intimately linked with Windows (they will come with a clean reinstall), the only way was to uninstall safely (through Program Uninstall) a lot of the Asus stuff.

Everything installed fine. When launching game (even after adding it to DEP list), after the intro video I can only see my cursor and a black screen. If I press Enter, Esc or Space on my keyboard, the game will exit. If I press any other keys, Windows will give me the "error" sound. If I use something like TRAWindowed and skip the intro video, it crashes and gives me the fatal error message.

I tried installing the June 2010 SDK redist and web installer, as well as adding the OPENSSL_ia32cap variable to environmental variables in system properties. I tried running it through clean boot to see if any services (particularly the services forced on my laptop like armory crate stuff) was interfering. I did basic stuff like disabling full screen optimization and running it as administrator. I tried turning off threaded optimization and have my laptop just run the game off my discrete GPU (NVIDIA GeForce RTX 3080 Laptop GPU) through the Nvidia Control Panel. Note that my laptop is capable of Advanced Optimus. Windows Power Plan is set to Balanced, with no change in its settings. I made Windows force TRL to run with the integrated Intel GPU. The game opens the settings and I can see that I can now only use that GPU. Unfortunately, the same thing happens and it crashes/freezes immediately after intro.

Nothing changed the outcome. Note that I installed the game in my old laptop and it works just fine (I still have access to that laptop if you want me to test something). Tomb Raider Anniversary works fine. Could be the CPU, but I already tried setting the affinity to 1 or 2 cores.

Edit: I forgot to say I tried the .Exe fix thing with the Retail version (I bought my game from GoG). Also, I've tried using System Configuration to boot my laptop with just 4 processors working, but still didn't do much.

OS: Windows 10 Pro 64-bit
Processor: 11th Gen Intel(R) Core(TM) i9-11900H @ 2.50GHz (16 CPUs), ~2.5GHz
Discrete GPU: NVIDIA GeForce RTX 3080 Laptop GPU
Last edited: