Universal Serial Bus (USB) Controller, PCI Simple Communications Controller, and ACPI Unknow Device: Driver Problems

Nov 27, 2015
8
0
4,510
0
Universal Serial Bus (USB) Controller, PCI Simple Communications Controller, and ACPI Unknow Device: Driver Problems

System Specs:
CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s)
Motherboard: Asrock Fatal1ty B150 Gaming K4
Ram: Corsair Vengeance LPX 2400MHz 16gb 2x8gb
PSU: Corsair CX750M v2.3 New 4th Gen
HDD: Seagate Barracuda ST1000DM003
OS: Windows 7 Ultimate x64

Three Drivers are having problems installing and i get the same errors for all three, Ive installed windows 13 times with no luck as well as installing all the drivers from the webpage for my motherboard. Ive searched online and gone through hundreds of forums and solutions with no luck. This has been going on for the past 2 weeks now and I havnt been able to find any solution that works.

I get error code 28, Install Error E0000203 "There is no driver selected for the device information set or element", and problem code 0000001C for all drivers.

Any help would be appreciated, Thanks in advanced :)
 

Mark_1970

Reputable
Nov 14, 2015
1,391
0
5,960
307

Installing these?
http://www.asrock.com/mb/Intel/Fatal1ty%20B150%20Gaming%20K4/?cat=Download&os=Win764

in particular the INF driver(first install) , Intel USB 3.0 driver, Intel Management Engine drive, Atheros Killer Lan driver. Need to unzip compressed files before install can commence (WinRAR)
 
Nov 27, 2015
8
0
4,510
0


Thanks for the reply :), I had installed the LAN driver during windows installation under "load driver" so that i would have access to the Net so i could download the rest of my drivers, the first thing i installed after that was the INF from asrock site for my motherboard. are you saying i should uninstall all the drivers and install them in that order? I installed MEI and that took care of the PCI Communications driver, now its just the Universal Serial Bus Controller and the unknown device. Also if i Try to install USB 3.0 drivers for my motherboard all the USB ports stop working.
 

Mark_1970

Reputable
Nov 14, 2015
1,391
0
5,960
307


is usb 3.0 enabled in bios? unknown device is probably amda00, this can be troublesome to setup, meant to setup when drivers disk starts but often does not, nobody has solved that yet.
 
Nov 27, 2015
8
0
4,510
0


Yes 3.0 is enabled in bios, but the minute I install windwind driver for 3.0 all my USB ports stop and ps/2 simulation in windows stops so it leaves me unable to do anything except reinstall Windows and start over.
 
Nov 27, 2015
8
0
4,510
0


wont work if my USB ports arnt recognized by windows. The problem is The Universal Serial Bus (USB) driver, USB 2.0 isnt recognized in windows cuz this driver is messed up. Ill try to see if i can download it directly to the computer, by installing my LAN driver via 'load driver" during windows installation
 

Similar threads